Драйвер Nvidia активирован, но в настоящее время он не используется

Я только что закончил установку ubuntu 11.04 beta 2. В конце установки я получил сообщение, сообщающее, что у меня нет необходимого оборудования для единства, и что я должен выбрать «ubuntu classic».

Может кто-то пролить свет на то, как это исправить? Я попытался добавить драйвер «экспериментального 3d xyz», но все равно не повезло.

Моя графическая карта - nvidia 240gt или gt240, я не могу вспомнить, какой путь вокруг нее.

Я включил «экспериментальную 3d-поддержку карт nvidia» - это то, о чем я говорил выше, а не о драйвере - извините.

20
задан Ole Christian 1 May 2011 в 14:17
поделиться

65 ответов

Вы можете проверить единство-2d, так как это будет резервная среда от 11.10. Насколько я понимаю, ваша графическая карта не соответствует требованиям единства 3d, которые являются средой рабочего стола по умолчанию. Вы можете попробовать gnome classic desktop, который по-прежнему доступен.

См. Здесь информацию об аппаратных требованиях.

Оформить заказ здесь для установки единицы-2d. В 11.04 вы можете установить single-2d:

Как установить и переключиться на рабочий стол Unity 2D?

EDIT: Как я вижу скриншот, я могу рекомендовать только один активный драйвер, а не оба. Я думаю, что есть много вопросов относительно новых Nvidia и Ubuntu

-2
ответ дан Community 25 July 2018 в 19:09
поделиться

Кажется, это ошибка в приложении, которое проверяет обновление драйверов - жокей.

Вы можете проверить, используется ли он по крайней мере тремя способами. Проверьте команды и выходы следующие:

/usr/lib/nux/unity_support_test -p

lspci | grep nVidia

enter image description here [!d5]

sudo lshw -C display

это .

4
ответ дан desgua 25 July 2018 в 19:09
поделиться

У меня была эта же проблема, но ни один из ответов здесь не исправил ее для меня. Я в конце концов исправил это, выполнив это:

sudo modprobe nvidia

Который дал мне предупреждение, что nvidia_319 был каким-то образом занесен в черный список ...? Итак, я сделал:

$ cd /etc/modprobe.d $ sudo fgrep nvidia * | fgrep blacklist

, который сообщил мне, что моя ранняя установка шмеля ломала обычные драйверы nvidia. Поэтому я сделал:

$ sudo apt-get remove bumblebee $ sudo rm bumblebee.conf

И это устранило проблему. Если у вас есть эта проблема, возможно, это не проблема с bumbleebee, но если ваши драйверы nvidia каким-то образом занесены в черный список, этот метод скажет вам, что их делает черный список и почему, и вы можете попытаться с этим справиться. Меню «Дополнительные драйверы» и jockey-text -l не сообщают вам, что это может быть проблемой черного списка.

Если вышеуказанный или любой другой ответ не помогает, сделайте уверенный, что нуво занесено в черный список, а затем переустановите драйверы nvidia. Установка nvidia должна сделать это для вас, сделав файл что-то вроде этого (но если это не так, скопируйте его и убедитесь, что в черный список включены все драйверы, но тот, который вы не хотите использовать)

/etc/modprobe.d/nvidia-graphics-drivers.conf:

blacklist nouveau blacklist lbm-nouveau blacklist nvidia-173 blacklist nvidia-96 alias nvidia nvidia-current
0
ответ дан durron597 25 July 2018 в 19:09
поделиться

Чтобы процитировать ваш скриншот,

Этот драйвер активирован, но не используется.

Перезапустили ли вы после установки драйвера Nvidia? Вы не можете использовать его, пока старый драйвер все еще загружен в ядро.

1
ответ дан Egil 25 July 2018 в 19:09
поделиться
  • 1
    BTW, у меня GT240, и Unity работает просто из коробки ... – Extender 26 April 2011 в 13:36
  • 2
    У меня такая же проблема. После перезагрузки и не повезло. Что я мог сделать дальше? спасибо ~ – sam 11 May 2015 в 05:16

У меня такая же конфигурация и точно такое же сообщение, как и вы. Но фраза «драйвер, который в настоящее время не используется», неверен. Используется драйвер. Проверьте glxgears, если у вас есть ~ 7800 кадров в секунду, просто расслабьтесь.

3
ответ дан Extender 25 July 2018 в 19:09
поделиться

Я думаю, что у вас установлен драйвер nvidia как пакет deb, но не сам драйвер, поэтому вам нужны заголовки ядра для этого, я думаю, из терминала

sudo apt-get install linux-headers-2.6.38-8-generic-pae sudo apt-get install linux-image-2.6.38-8-generic-pae

или просто ищут их в синаптических

-2
ответ дан Jorge Castro 25 July 2018 в 19:09
поделиться

Собственные драйверы в Ubuntu являются драйверами для ваших аппаратных устройств, которые не являются свободно доступными или с открытым исходным кодом и должны быть получены от производителя оборудования. Драйвер бесплатного и открытого источника, Nouveau, является драйвером, который Ubuntu будет использовать по умолчанию для графических карт Nvidia. Nouveau не поддерживает 3D и может вообще не работать с новейшими видеокартами от Nvidia. Собственные драйверы, закрытый источник, являются альтернативой Nouveau, и большинство времени обеспечивают превосходное трехмерное ускорение и общую поддержку / производительность видеокарты. Следуйте этим инструкциям, чтобы установить проприетарные драйверы для вашей видеокарты Nvidia.

0
ответ дан Troubled Ubuntu 25 July 2018 в 19:09
поделиться

Вы можете проверить единство-2d, так как это будет резервная среда от 11.10. Насколько я понимаю, ваша графическая карта не соответствует требованиям единства 3d, которые являются средой рабочего стола по умолчанию. Вы можете попробовать gnome classic desktop, который по-прежнему доступен.

См. Здесь информацию об аппаратных требованиях.

Оформить заказ здесь для установки единицы-2d. В 11.04 вы можете установить single-2d:

Как установить и переключиться на рабочий стол Unity 2D?

EDIT: Как я вижу скриншот, я могу рекомендовать только один активный драйвер, а не оба. Я думаю, что есть много вопросов относительно новых Nvidia и Ubuntu

6
ответ дан Community 31 July 2018 в 07:35
поделиться

Кажется, это ошибка в приложении, которое проверяет обновление драйверов - жокей.

Вы можете проверить, используется ли он по крайней мере тремя способами. Проверьте команды и выходы следующие:

/usr/lib/nux/unity_support_test -p

lspci | grep nVidia

enter image description here [!d5]

sudo lshw -C display

это .

7
ответ дан desgua 31 July 2018 в 07:35
поделиться

У меня была эта же проблема, но ни один из ответов здесь не исправил ее для меня. Я в конце концов исправил это, выполнив это:

sudo modprobe nvidia

Который дал мне предупреждение, что nvidia_319 был каким-то образом занесен в черный список ...? Итак, я сделал:

$ cd /etc/modprobe.d $ sudo fgrep nvidia * | fgrep blacklist

, который сообщил мне, что моя ранняя установка шмеля ломала обычные драйверы nvidia. Поэтому я сделал:

$ sudo apt-get remove bumblebee $ sudo rm bumblebee.conf

И это устранило проблему. Если у вас есть эта проблема, возможно, это не проблема с bumbleebee, но если ваши драйверы nvidia каким-то образом занесены в черный список, этот метод скажет вам, что их делает черный список и почему, и вы можете попытаться с этим справиться. Меню «Дополнительные драйверы» и jockey-text -l не сообщают вам, что это может быть проблемой черного списка.

Если вышеуказанный или любой другой ответ не помогает, сделайте уверенный, что нуво занесено в черный список, а затем переустановите драйверы nvidia. Установка nvidia должна сделать это для вас, сделав файл что-то вроде этого (но если это не так, скопируйте его и убедитесь, что в черный список включены все драйверы, но тот, который вы не хотите использовать)

/etc/modprobe.d/nvidia-graphics-drivers.conf:

blacklist nouveau blacklist lbm-nouveau blacklist nvidia-173 blacklist nvidia-96 alias nvidia nvidia-current
0
ответ дан durron597 31 July 2018 в 07:35
поделиться

Чтобы процитировать ваш скриншот,

Этот драйвер активирован, но не используется.

Перезапустили ли вы после установки драйвера Nvidia? Вы не можете использовать его, пока старый драйвер все еще загружен в ядро.

1
ответ дан Egil 31 July 2018 в 07:35
поделиться
  • 1
    BTW, у меня GT240, и Unity работает просто из коробки ... – Extender 26 April 2011 в 13:36
  • 2
    У меня такая же проблема. После перезагрузки и не повезло. Что я мог сделать дальше? спасибо ~ – sam 11 May 2015 в 05:16

У меня такая же конфигурация и точно такое же сообщение, как и вы. Но фраза «драйвер, который в настоящее время не используется», неверен. Используется драйвер. Проверьте glxgears, если у вас есть ~ 7800 кадров в секунду, просто расслабьтесь.

3
ответ дан Extender 31 July 2018 в 07:35
поделиться

Я думаю, что у вас установлен драйвер nvidia как пакет deb, но не сам драйвер, поэтому вам нужны заголовки ядра для этого, я думаю, из терминала

sudo apt-get install linux-headers-2.6.38-8-generic-pae sudo apt-get install linux-image-2.6.38-8-generic-pae

или просто ищут их в синаптических

-2
ответ дан Jorge Castro 31 July 2018 в 07:35
поделиться

Собственные драйверы в Ubuntu являются драйверами для ваших аппаратных устройств, которые не являются свободно доступными или с открытым исходным кодом и должны быть получены от производителя оборудования. Драйвер бесплатного и открытого источника, Nouveau, является драйвером, который Ubuntu будет использовать по умолчанию для графических карт Nvidia. Nouveau не поддерживает 3D и может вообще не работать с новейшими видеокартами от Nvidia. Собственные драйверы, закрытый источник, являются альтернативой Nouveau, и большинство времени обеспечивают превосходное трехмерное ускорение и общую поддержку / производительность видеокарты. Следуйте этим инструкциям, чтобы установить проприетарные драйверы для вашей видеокарты Nvidia.

0
ответ дан Troubled Ubuntu 31 July 2018 в 07:35
поделиться

Вы можете проверить единство-2d, так как это будет резервная среда от 11.10. Насколько я понимаю, ваша графическая карта не соответствует требованиям единства 3d, которые являются средой рабочего стола по умолчанию. Вы можете попробовать gnome classic desktop, который по-прежнему доступен.

См. Здесь информацию об аппаратных требованиях.

Оформить заказ здесь для установки единицы-2d. В 11.04 вы можете установить single-2d:

Как установить и переключиться на рабочий стол Unity 2D?

EDIT: Как я вижу скриншот, я могу рекомендовать только один активный драйвер, а не оба. Я думаю, что есть много вопросов относительно новых Nvidia и Ubuntu

6
ответ дан Community 31 July 2018 в 08:39
поделиться

Кажется, это ошибка в приложении, которое проверяет обновление драйверов - жокей.

Вы можете проверить, используется ли он по крайней мере тремя способами. Проверьте команды и выходы следующие:

/usr/lib/nux/unity_support_test -p

lspci | grep nVidia

enter image description here [!d5]

sudo lshw -C display

это .

7
ответ дан desgua 31 July 2018 в 08:39
поделиться

У меня была эта же проблема, но ни один из ответов здесь не исправил ее для меня. Я в конце концов исправил это, выполнив это:

sudo modprobe nvidia

Который дал мне предупреждение, что nvidia_319 был каким-то образом занесен в черный список ...? Итак, я сделал:

$ cd /etc/modprobe.d $ sudo fgrep nvidia * | fgrep blacklist

, который сообщил мне, что моя ранняя установка шмеля ломала обычные драйверы nvidia. Поэтому я сделал:

$ sudo apt-get remove bumblebee $ sudo rm bumblebee.conf

И это устранило проблему. Если у вас есть эта проблема, возможно, это не проблема с bumbleebee, но если ваши драйверы nvidia каким-то образом занесены в черный список, этот метод скажет вам, что их делает черный список и почему, и вы можете попытаться с этим справиться. Меню «Дополнительные драйверы» и jockey-text -l не сообщают вам, что это может быть проблемой черного списка.

Если вышеуказанный или любой другой ответ не помогает, сделайте уверенный, что нуво занесено в черный список, а затем переустановите драйверы nvidia. Установка nvidia должна сделать это для вас, сделав файл что-то вроде этого (но если это не так, скопируйте его и убедитесь, что в черный список включены все драйверы, но тот, который вы не хотите использовать)

/etc/modprobe.d/nvidia-graphics-drivers.conf:

blacklist nouveau blacklist lbm-nouveau blacklist nvidia-173 blacklist nvidia-96 alias nvidia nvidia-current
0
ответ дан durron597 31 July 2018 в 08:39
поделиться

Чтобы процитировать ваш скриншот,

Этот драйвер активирован, но не используется.

Перезапустили ли вы после установки драйвера Nvidia? Вы не можете использовать его, пока старый драйвер все еще загружен в ядро.

1
ответ дан Egil 31 July 2018 в 08:39
поделиться
  • 1
    BTW, у меня GT240, и Unity работает просто из коробки ... – Extender 26 April 2011 в 13:36
  • 2
    У меня такая же проблема. После перезагрузки и не повезло. Что я мог сделать дальше? спасибо ~ – sam 11 May 2015 в 05:16

У меня такая же конфигурация и точно такое же сообщение, как и вы. Но фраза «драйвер, который в настоящее время не используется», неверен. Используется драйвер. Проверьте glxgears, если у вас есть ~ 7800 кадров в секунду, просто расслабьтесь.

3
ответ дан Extender 31 July 2018 в 08:39
поделиться

Я думаю, что у вас установлен драйвер nvidia как пакет deb, но не сам драйвер, поэтому вам нужны заголовки ядра для этого, я думаю, из терминала

sudo apt-get install linux-headers-2.6.38-8-generic-pae sudo apt-get install linux-image-2.6.38-8-generic-pae

или просто ищут их в синаптических

-2
ответ дан Jorge Castro 31 July 2018 в 08:39
поделиться

Собственные драйверы в Ubuntu являются драйверами для ваших аппаратных устройств, которые не являются свободно доступными или с открытым исходным кодом и должны быть получены от производителя оборудования. Драйвер бесплатного и открытого источника, Nouveau, является драйвером, который Ubuntu будет использовать по умолчанию для графических карт Nvidia. Nouveau не поддерживает 3D и может вообще не работать с новейшими видеокартами от Nvidia. Собственные драйверы, закрытый источник, являются альтернативой Nouveau, и большинство времени обеспечивают превосходное трехмерное ускорение и общую поддержку / производительность видеокарты. Следуйте этим инструкциям, чтобы установить проприетарные драйверы для вашей видеокарты Nvidia.

0
ответ дан Troubled Ubuntu 31 July 2018 в 08:39
поделиться

Вы можете проверить единство-2d, так как это будет резервная среда от 11.10. Насколько я понимаю, ваша графическая карта не соответствует требованиям единства 3d, которые являются средой рабочего стола по умолчанию. Вы можете попробовать gnome classic desktop, который по-прежнему доступен.

См. Здесь информацию об аппаратных требованиях.

Оформить заказ здесь для установки единицы-2d. В 11.04 вы можете установить single-2d:

Как установить и переключиться на рабочий стол Unity 2D?

EDIT: Как я вижу скриншот, я могу рекомендовать только один активный драйвер, а не оба. Я думаю, что есть много вопросов относительно новых Nvidia и Ubuntu

6
ответ дан Community 2 August 2018 в 00:38
поделиться

Кажется, это ошибка в приложении, которое проверяет обновление драйверов - жокей.

Вы можете проверить, используется ли он по крайней мере тремя способами. Проверьте команды и выходы следующие:

/usr/lib/nux/unity_support_test -p

lspci | grep nVidia

enter image description here [!d5]

sudo lshw -C display

это .

7
ответ дан desgua 2 August 2018 в 00:38
поделиться

У меня была эта же проблема, но ни один из ответов здесь не исправил ее для меня. Я в конце концов исправил это, выполнив это:

sudo modprobe nvidia

Который дал мне предупреждение, что nvidia_319 был каким-то образом занесен в черный список ...? Итак, я сделал:

$ cd /etc/modprobe.d $ sudo fgrep nvidia * | fgrep blacklist

, который сообщил мне, что моя ранняя установка шмеля ломала обычные драйверы nvidia. Поэтому я сделал:

$ sudo apt-get remove bumblebee $ sudo rm bumblebee.conf

И это устранило проблему. Если у вас есть эта проблема, возможно, это не проблема с bumbleebee, но если ваши драйверы nvidia каким-то образом занесены в черный список, этот метод скажет вам, что их делает черный список и почему, и вы можете попытаться с этим справиться. Меню «Дополнительные драйверы» и jockey-text -l не сообщают вам, что это может быть проблемой черного списка.

Если вышеуказанный или любой другой ответ не помогает, сделайте уверенный, что нуво занесено в черный список, а затем переустановите драйверы nvidia. Установка nvidia должна сделать это для вас, сделав файл что-то вроде этого (но если это не так, скопируйте его и убедитесь, что в черный список включены все драйверы, но тот, который вы не хотите использовать)

/etc/modprobe.d/nvidia-graphics-drivers.conf:

blacklist nouveau blacklist lbm-nouveau blacklist nvidia-173 blacklist nvidia-96 alias nvidia nvidia-current
0
ответ дан durron597 2 August 2018 в 00:38
поделиться

Чтобы процитировать ваш скриншот,

Этот драйвер активирован, но не используется.

Перезапустили ли вы после установки драйвера Nvidia? Вы не можете использовать его, пока старый драйвер все еще загружен в ядро.

1
ответ дан Egil 2 August 2018 в 00:38
поделиться
  • 1
    BTW, у меня GT240, и Unity работает просто из коробки ... – Extender 26 April 2011 в 13:36
  • 2
    У меня такая же проблема. После перезагрузки и не повезло. Что я мог сделать дальше? спасибо ~ – sam 11 May 2015 в 05:16

У меня такая же конфигурация и точно такое же сообщение, как и вы. Но фраза «драйвер, который в настоящее время не используется», неверен. Используется драйвер. Проверьте glxgears, если у вас есть ~ 7800 кадров в секунду, просто расслабьтесь.

3
ответ дан Extender 2 August 2018 в 00:38
поделиться

Я думаю, что у вас установлен драйвер nvidia как пакет deb, но не сам драйвер, поэтому вам нужны заголовки ядра для этого, я думаю, из терминала

sudo apt-get install linux-headers-2.6.38-8-generic-pae sudo apt-get install linux-image-2.6.38-8-generic-pae

или просто ищут их в синаптических

-2
ответ дан Jorge Castro 2 August 2018 в 00:38
поделиться

Собственные драйверы в Ubuntu являются драйверами для ваших аппаратных устройств, которые не являются свободно доступными или с открытым исходным кодом и должны быть получены от производителя оборудования. Драйвер бесплатного и открытого источника, Nouveau, является драйвером, который Ubuntu будет использовать по умолчанию для графических карт Nvidia. Nouveau не поддерживает 3D и может вообще не работать с новейшими видеокартами от Nvidia. Собственные драйверы, закрытый источник, являются альтернативой Nouveau, и большинство времени обеспечивают превосходное трехмерное ускорение и общую поддержку / производительность видеокарты. Следуйте этим инструкциям, чтобы установить проприетарные драйверы для вашей видеокарты Nvidia.

0
ответ дан Troubled Ubuntu 2 August 2018 в 00:38
поделиться

Вы можете проверить единство-2d, так как это будет резервная среда от 11.10. Насколько я понимаю, ваша графическая карта не соответствует требованиям единства 3d, которые являются средой рабочего стола по умолчанию. Вы можете попробовать gnome classic desktop, который по-прежнему доступен.

См. Здесь информацию об аппаратных требованиях.

Оформить заказ здесь для установки единицы-2d. В 11.04 вы можете установить single-2d:

Как установить и переключиться на рабочий стол Unity 2D?

EDIT: Как я вижу скриншот, я могу рекомендовать только один активный драйвер, а не оба. Я думаю, что есть много вопросов относительно новых Nvidia и Ubuntu

6
ответ дан Community 4 August 2018 в 16:40
поделиться

Кажется, это ошибка в приложении, которое проверяет обновление драйверов - жокей.

Вы можете проверить, используется ли он по крайней мере тремя способами. Проверьте команды и выходы следующие:

/usr/lib/nux/unity_support_test -p

lspci | grep nVidia

enter image description here [!d5]

sudo lshw -C display

это .

7
ответ дан desgua 4 August 2018 в 16:40
поделиться

Другие вопросы по тегам:

Похожие вопросы: