Установка VLc в ubuntu 16.04? [dубликат]

Ах, какая чертовщина.

Короткий ответ: удалите \n из аргумента в scanf. Когда я это делаю, ваш код ведет себя так, как ожидалось (ну, чтобы быть непроницаемым, мне также пришлось изменить argv[] на *argv[].)

. Более длинный ответ: вы никогда не должны использовать scanf; это обычно приводит к неприятностям.

Хм ... мой более длинный ответ был короче моего короткого ответа. Ах, хорошо.

9
задан 6 February 2014 в 02:35

10 ответов

Попробуйте использовать

sudo apt-get update

, затем повторите попытку.

16
ответ дан 18 July 2018 в 01:17

Попробуйте использовать

sudo apt-get update

, затем повторите попытку.

16
ответ дан 24 July 2018 в 17:22

Попробуйте перейти на главный сервер под программным обеспечением и обновлениями в системных настройках. Затем используйте sudo apt-get update, а затем попробуйте установить. У меня была такая же проблема при установке диспетчера синаптических пакетов.

0
ответ дан 18 July 2018 в 01:17

Если sudo apt-get update также не работает, выполните следующие действия: -

Откройте файл /etc/apt/sources.list. Проверьте слово после http://security.ubuntu.com/ubuntu/ в файле sources.list, дайте ему слово xyz Перейдите к адресу http://security.ubuntu.com/ubuntu/, а затем щелкните по дискам. Теперь проверьте, присутствует ли xyz на этом пути. Если его нет, замените xyz на элемент, который присутствует в «dists», например: - уверенный, ясный, надежный и т. Д. Теперь запустите команду sudo apt-get update.
8
ответ дан 18 July 2018 в 01:17

Попробуйте изменить http://security.ubuntu.com/ubuntu на http://old-releases.ubuntu.com/ubuntu в /etc/apt/sources.list, затем запустите apt-get update

(вы можете проверить, есть ли у вас определенный дистрибутив, обратившись к старым версиям http: //. ubuntu.com/ubuntu/ в вашем браузере, а затем выберите / dists, но если это не на security.ubuntu.com, оно должно быть на старых версиях

0
ответ дан 18 July 2018 в 01:17

Есть команда указывать исходные URL-адреса в версиях старых.

объяснение goog в этом github gist:

https://gist.github.com/dergachev/f5da514802fcbbb441a1

1
ответ дан 18 July 2018 в 01:17

Попробуйте перейти на главный сервер под программным обеспечением и обновлениями в системных настройках. Затем используйте sudo apt-get update, а затем попробуйте установить. У меня была такая же проблема при установке диспетчера синаптических пакетов.

0
ответ дан 24 July 2018 в 17:22
  • 1
    Перед тем, как попытаться перейти на главный сервер, перейдите на URL-адрес, который дает сообщение 404 Not Found в веб-браузере, чтобы проверить, не работает ли он. – karel 5 August 2017 в 07:35

Если sudo apt-get update также не работает, выполните следующие действия: -

Откройте файл /etc/apt/sources.list. Проверьте слово после http://security.ubuntu.com/ubuntu/ в файле sources.list, дайте ему слово xyz Перейдите к адресу http://security.ubuntu.com/ubuntu/, а затем щелкните по дискам. Теперь проверьте, присутствует ли xyz на этом пути. Если его нет, замените xyz на элемент, который присутствует в «dists», например: - уверенный, ясный, надежный и т. Д. Теперь запустите команду sudo apt-get update.
8
ответ дан 24 July 2018 в 17:22
  • 1
    +1. Но одно примечание: если это произойдет, это означает, что ваш linux больше не поддерживается, и в этом случае имеет смысл перейти на более новую версию. – ntg 22 April 2016 в 17:18
  • 2
    это действительно лучший ответ, чем принятый. См. Комментарий ntg tho – Dredok 5 April 2018 в 19:13

Попробуйте изменить http://security.ubuntu.com/ubuntu на http://old-releases.ubuntu.com/ubuntu в /etc/apt/sources.list, затем запустите apt-get update

(вы можете проверить, есть ли у вас определенный дистрибутив, обратившись к старым версиям http: //. ubuntu.com/ubuntu/ в вашем браузере, а затем выберите / dists, но если это не на security.ubuntu.com, оно должно быть на старых версиях

0
ответ дан 24 July 2018 в 17:22

Есть команда указывать исходные URL-адреса в версиях старых.

объяснение goog в этом github gist:

https://gist.github.com/dergachev/f5da514802fcbbb441a1

1
ответ дан 24 July 2018 в 17:22
  • 1
    Вам не нужно идти в Github для этого, у нас есть один здесь: askubuntu.com/q/91815/158442 . Тем не менее, здесь это не применимо, поскольку OP использует 12.04 и 12.04. – muru 20 February 2015 в 16:46

Другие вопросы по тегам:

Похожие вопросы: