С ошибками встретились при обработке:/var/cache/apt/archives/snapd_2.32.9_amd64.deb

Хотя вы можете настроить репо и установить его вручную для документов, существует более быстрый способ.

Начиная с июля 2017 года, чтобы установить docker-ce на Ubuntu 16.04, команда для автоматического install:

curl https://get.docker.com | sudo sh

Прочтите примечание по безопасности, напечатанное на выходе в конце установки. Обратите внимание, что скрипт по указанному выше URL-адресу сохраняется в репозитории docs .

Это устанавливает пакет и репо. Чтобы подтвердить:

$ apt list docker-ce 2>&- | grep installed
docker-ce/xenial,now 17.06.0~ce-0~ubuntu amd64 [installed]

$ grep docker /etc/apt/sources.list
deb [arch=amd64] https://download.docker.com/linux/ubuntu xenial edge
# deb-src [arch=amd64] https://download.docker.com/linux/ubuntu xenial edge

Не волнуйтесь при просмотре только edge, а не stable выше. В документах

Примечание. Начиная с Docker 17.06, стабильные релизы также переносятся на край и тестируют репозитории.

Проверить установку:

sudo docker run hello-world

Продолжить работу с docs .

2
задан 20 June 2018 в 17:05

2 ответа

Вы должны быть в состоянии удалить ubuntu-core-launcher, так как я не думаю, что это больше нужно.

sudo apt remove ubuntu-core-launcher

Что может улучшить ваши апгрейды.

0
ответ дан 20 June 2018 в 17:05

sudo apt remove ubuntu-core-launcher

также создает следующую ошибку

Чтение списков пакетов ... Готово Построение дерева зависимостей
Чтение информации о состоянии ... Готово Пакет 'ubuntu-core-launcher' не установлен, поэтому не удален Вы можете запустить 'apt --fix-broken install', чтобы исправить это. Следующие пакеты имеют неудовлетворенные зависимости: default-jdk: Зависит от: openjdk-11-jdk, но он не будет установлен. E: Невыполненные зависимости. Попробуйте 'apt --fix-broken install' без пакетов (или укажите решение).

любая помощь плз

0
ответ дан 20 June 2018 в 17:05

Другие вопросы по тегам:

Похожие вопросы: