Заставьте chromium и firefox использовать TLS 1.2

Обратите внимание: файлы должны быть исполняемыми - вы можете выполнить следующую команду в каталоге, где хранятся файлы .sh, перед запуском вышеуказанного скрипта:
chmod +x *.sh

Следующий скрипт будет возьмите все файлы с помощью .sh и выполните их.

#/bin/bash
for shfile in *.sh
do
    ./$shfile
done

Вы можете скопировать / вставить указанные выше строки (без первой строки #/bin/bash) в свой терминал, и это сделает трюк (спасибо @terdon за ваш комментарий).

Вы можете сохранить этот скрипт в другой папке (например, /tmp/execute_all.sh и сделать его выполнимым с помощью:

chmod +x /tmp/execute_all.sh

Затем перейдите в каталог с файлами .sh и выполнить сценарий, используя:

/tmp/execute_all.sh

Сценарий попытается выполнить все файлы, заканчивающиеся на .sh

2
задан 8 February 2014 в 23:51

1 ответ

Заставьте Firefox использовать нужную версию TLS:

  • Запишите в адресной строке: about:config
  • Подтвердите, чтобы продолжить

Настройки по умолчанию: :

security.tls.version.min = 0
security.tls.version.max = 1
  • 1 = TLS 1.0
  • 2 = TLS 1.1
  • 3 = TLS 1.2

Установите значения, которые вы нужно.

0
ответ дан 8 February 2014 в 23:51

Другие вопросы по тегам:

Похожие вопросы: