& ldquo; Требовать установки ненадежных пакетов & rdquo; при обновлении с помощью диспетчера обновлений

Сконфигурируйте exim4:

sudo dpkg-reconfigure exim4

Один из вопросов, который он задал вам, - это имя «System mail name». Вы хотите это изменить.

66
задан 3 November 2014 в 23:28

7 ответов

  1. Запишите в терминале: sudo apt-get update && sudo apt-get upgrade или измените настройки диспетчера обновлений (попробуйте сначала, если вы уже настроили диспетчер обновлений).

    CLI

  2. Запустите диспетчер обновлений и повторите попытку.

    GUI

Запуск обновления через терминал дает возможность разрешить или запретить ненадежные пакеты.

WARNING: The following packages cannot be authenticated!
  playonlinux
Install these packages without verification [y/N]?

Если вы доверяете источнику пакета, введите y.

0
ответ дан 3 November 2014 в 23:28

Это происходит из-за отсутствия некоторых ключей GPG. Чтобы это исправить, откройте терминал и выполните следующие команды:

sudo apt-get update

Вы получите сообщение о том, что какой-то открытый ключ недоступен. Запишите ключевую строку (после NO_PUBKEY; например: D6B6DB186A68F637)

 gpg --keyserver keyserver.ubuntu.com --recv XXXXX

Замените XXXXX на ключевую строку

, например: gpg --keyserver keyserver.ubuntu.com --recv D6B6DB186A68F637

gpg --export --armor  XXXXX | sudo apt-key add -

например : gpg --export --armor D6B6DB186A68F637 | sudo apt-key add -

sudo apt-get update

Теперь попробуйте обновить систему еще раз.

Вот аналогичный пост: & quot; Требуется установить ненадежные обновления & quot; Ошибка в диспетчере обновлений

Надеюсь, это поможет.

0
ответ дан 3 November 2014 в 23:28

Вы можете установить его через командную строку: sudo apt-get install --allow-unauthenticated exiv2.

Чтобы навсегда «доверять» репо, выполните следующее: sudo apt-add-repository ppa:pmjdebruijn/darktable-release && sudo apt-get update. Я считаю, что вы используете PPA.

0
ответ дан 3 November 2014 в 23:28

Почему такое выражение означает, что пакеты, которые вы пытаетесь установить, являются сторонним программным обеспечением. Поэтому, если вы хотите установить их, включите флажок Canonical на вкладке другого программного обеспечения в настройках диспетчера обновлений и попробуйте снова установка.

надеюсь, что это помогает.

0
ответ дан 3 November 2014 в 23:28

У меня была такая же проблема. Для меня эта команда сработала:

sudo apt-get update --fix-missing

Преимущество этого по сравнению с другими решениями заключается в его простоте. Вы можете продолжать использовать графический интерфейс, и вам не нужно узнавать, какой репозиторий поврежден. Я нашел решение здесь в комментарии. Я не знаю Ubuntu достаточно, чтобы объяснить, но я полагаю, что он получает ключи, необходимые для работы всех репозиториев.

0
ответ дан 3 November 2014 в 23:28

Ваш вопрос неясен: вы исправляете обновление GUI, исправляя ошибку. Другой вопрос покажет вам, что делать.

Вы можете отменить выбор любого из ваших обновлений, полагаясь на ненадежный источник, или вы можете пойти дальше и использовать командную строку для постоянного доверия этому конкретному источнику. После того как вы сделали один из них, сообщение не появится. Если вы сделаете последнее, сообщение больше не будет появляться для этого конкретного источника.

0
ответ дан 3 November 2014 в 23:28

Отвечая на ваш вопрос, вы не можете «исправить» обновление GUI (т. Е. Менеджер обновлений), поскольку очевидно, что это приложение в настоящее время не имеет возможности устанавливать ненадежные пакеты. Если вы хотите установить ненадежные пакеты, вы должны сделать это в командной строке.

Однако есть два способа, которыми вы можете помешать Update Manager сообщать об этой ошибке: либо удалить ненадежное программное обеспечение из вашей системы, либо доверить соответствующий репозиторий, как указано в ответе на другой вопрос. ( Обновления не устанавливаются из-за «ненадежных пакетов» ).

Первый шаг - выяснить, какой репозиторий является причиной проблемы. Вы можете узнать это, набрав apt-cache policy ambiance-colors в командной строке.

Тем не менее, быстрый Google показывает, что ambiance-colors и radiance-colors из ppa:ravefinity-project. Таким образом, вы сможете решить вашу проблему, набрав

sudo add-apt-repository ppa:ravefinity-project/ppa
sudo apt-get update
sudo apt-get install ambiance-colors radiance-colors

, взятые из http://www.webupd8.org/2012/01/ambiance-and-radiance-colors-theme-pack .html

0
ответ дан 3 November 2014 в 23:28

Другие вопросы по тегам:

Похожие вопросы: