Почему изображение в VirtualBox 5.2.18 не работает с последней версией VirtualBox 6.0.8?

Проверьте GMailWatcher. Он все еще находится на ранней стадии разработки, но работает достаточно хорошо. Я использую его уже более месяца. Рекомендуемый.

Вводный блогпост: owaislone.org/blog/2010/jul/gmail-watcher URL-адрес запуска: https://launchpad.net/gmailwatcher

PPA

$ sudo add-apt-repository ppa:loneowais/ppa $ sudo apt-get update && sudo apt-get install gmailwatcher
2
задан 22 June 2019 в 11:49

2 ответа

У меня возникла та же проблема при установке virtualbox 6, когда Virtualbox 5 уже установлен. Перед установкой virtualbox-6.0 я только что попробовал

sudo apt remove virtualbox

, а затем

sudo apt install virtualbox-6.0

, но при попытке «подходящего обновления» получилось:

The following packages have unmet dependencies:
virtualbox-6.0 : Conflicts: virtualbox
                 Conflicts: virtualbox-qt but 5.2.18-dfsg-2~ubuntu18.04.5 is to be installed

, поэтому я понял, что был какой-то пакет, не исправленный.

sudo apt autoremove --purge virtualbox*
sudo apt install virtualbox-6.0

, наконец, работал для меня.

0
ответ дан 22 June 2019 в 11:49

«Модуль ядра Virtualbox не соответствует этой версии virtualbox»

Я думаю, это объясняется довольно хорошо.

Ваш установленный модуль ядра virtualbox по-прежнему является 5.x.x. Но ваша установленная версия virtualbox - 6.x.x. Существует несоответствие .

Выгрузка модулей

Вы можете вручную выгрузить модуль (-и).

sudo modprobe -r vboxpci
sudo modprobe -r vboxnetadp
sduo mdoprobe -r vboxnetflt
[...]
sudo modprobe -r vboxdrv

Примечание: не возражайте, если модуль отчетов modprobe не найден

Затем перезапустите virtualbox.

Перезагрузите

... или ( нет и ) вы можете просто перезагрузиться.

0
ответ дан 22 June 2019 в 11:49

Другие вопросы по тегам:

Похожие вопросы: