Атом PPA не найден в Ubuntu 19

Проверьте GMailWatcher. Он все еще находится на ранней стадии разработки, но работает достаточно хорошо. Я использую его уже более месяца. Рекомендуемый.

Вводный блогпост: owaislone.org/blog/2010/jul/gmail-watcher URL-адрес запуска: https://launchpad.net/gmailwatcher

PPA

$ sudo add-apt-repository ppa:loneowais/ppa $ sudo apt-get update && sudo apt-get install gmailwatcher
0
задан 20 June 2019 в 22:34

1 ответ

На странице Launchpad для этого PPA , под Обзор опубликованных пакетов , самый последний выпуск, для которого PPA содержит пакеты, - это Bionic, который является кодовым именем . ] для Ubuntu 18.04 LTS. Итак, Орхан Г. Хафиф прав , что PPA в настоящее время не поддерживает 19.04 и что вам следует следовать официальным инструкциям по установке Atom. Кроме того, собственное описание PPA на этой странице Launchpad рекомендует:

Пожалуйста, используйте вместо этого официальный репозиторий: https://flight-manual.atom.io/getting-started/sections/install -atom / # platform-linux

Так как сопровождающие PPA больше не рекомендуют людям использовать PPA, похоже, что они не будут добавлять пакеты в него для более новых выпусков Ubuntu.

Подведем итог первого рекомендуемого подхода в официальных инструкциях (с некоторыми незначительными изменениями, которые по сути являются стилистическими):

  1. Добавьте ключ подписи, чтобы APT знал, как доверять хранилищу:

    wget -qO - https://packagecloud.io/AtomEditor/atom/gpgkey | sudo apt-key add -
    
  2. Добавьте репозиторий:

    sudo sh -c 'echo "deb [arch=amd64] https://packagecloud.io/AtomEditor/atom/any/ any main" > /etc/apt/sources.list.d/atom.list'
    
  3. Обновите информацию APT, хранящуюся о том, какие пакеты доступны из каких репозиториев и, предполагая, что успешно, установите пакет atom:

    sudo apt update && sudo apt install atom
    

    Если вы хотите бета-версию Atom, то установите пакет atom-beta вместо пакета atom.

Я предлагаю взглянуть на официальные инструкции , а не просто работать с этим постом (хотя в любом случае это должно быть хорошо).


Если по какой-то причине вы не хотите этого делать, а также не хотите использовать пакет моментальных снимков, вы можете искать Launchpad для других PPA ; просто имейте в виду, что не каждый пакет с atom в названии связан с текстовым редактором Atom. Но вы можете не найти актуальный PPA , которому вы доверяете и который поддерживает ваш выпуск Ubuntu.

Хотя я не особо рекомендую это, вы можете попытаться установить Atom из файла .deb, предоставленного на веб-сайте, atom.io . Его можно скачать по ссылке там или на этой странице , где вам нужен файл atom-amd64.deb. Это будет работать, только если вы используете ПК или Mac с 64-битным процессором. (Однако не нужно, чтобы был процессором AMD.) Обратите внимание также, что, если вы установите его таким образом, вы не получите автоматическое обновление более новых версий Atom.

Если вы выполняете установку вручную из загруженного файла .deb, одним из хороших способов является использование gdebi, которое заботится об установке любых отсутствующих зависимостей. Это можно сделать, запустив sudo gdebi atom-amd64.deb в каталоге, в который вы скачали atom-amd64.deb. Но опять же, это, вероятно, не лучший способ.

1
ответ дан 20 June 2019 в 22:34

Другие вопросы по тегам:

Похожие вопросы: