apt install не устанавливает python3.6 [закрыто]

Проверьте GMailWatcher. Он все еще находится на ранней стадии разработки, но работает достаточно хорошо. Я использую его уже более месяца. Рекомендуемый.

Вводный блогпост: owaislone.org/blog/2010/jul/gmail-watcher URL-адрес запуска: https://launchpad.net/gmailwatcher

PPA

$ sudo add-apt-repository ppa:loneowais/ppa $ sudo apt-get update && sudo apt-get install gmailwatcher
0
задан 20 June 2019 в 19:14

1 ответ

Оказывается, большинство людей ожидают, что вы установите через apt, поэтому поиск альтернативных методов установки python был не самым простым, поэтому здесь я опишу различные методы

Метод 1

Первый метод, который работал для друга, работавшего в том же дистрибутиве, что и я (pop_os), состоял в том, чтобы избежать периода в команде apt install

sudo apt install python3\.6

Метод 2

Второй метод - установка напрямую без инструмент установки

# Install dependancies
$ sudo apt install build-essential checkinstall
$ sudo apt install libreadline-gplv2-dev libncursesw5-dev libssl-dev libsqlite3-dev tk-dev libgdbm-dev libc6-dev libbz2-dev

# Retrieve and unzip package
$ wget https://www.python.org/ftp/python/3.6.0/Python-3.6.0.tar.xz
$ tar xvf Python-3.6.0.tar.xz

# Make
$ cd Python-3.6.0/
$ ./configure
$ sudo make altinstall

Если у вас возникли проблемы make ing, попробуйте установить zlib1g через sudo apt-get install zlib1g-dev

1
ответ дан 20 June 2019 в 19:14

Другие вопросы по тегам:

Похожие вопросы: