Как исправить испорченные пакеты glibc

Мне повезло с CheckGmail. Обладает приятным графическим интерфейсом, прохладными всплывающими заголовками тостеров и позволяет выполнять действия с электронной почтой из лотка.

sudo apt-get install checkgmail; checkgmail &
0
задан 19 June 2019 в 23:45

2 ответа

Я исправил, загрузив 2.27-версию всех этих пакетов и запустив на них dpkg.

Я пытался установить их в том же порядке, прежде чем сломался. Я использовал dpkg для нескольких файлов deb, чтобы предотвратить циклические зависимости или что-то подобное. Не уверен, что это что-то меняет.

1
ответ дан 19 June 2019 в 23:45

Apt не сломан - он все еще работает просто отлично. Но вы неразумно сказали apt создать Frankensystem , смешивая пакеты из разных выпусков Ubuntu.

Апт не сможет решить ныне нелогичные зависимости ... никогда. (Вы тоже не будете). Поскольку apt не может работать, вы никогда не получите больше обновлений и исправлений безопасности, пока не удалите пакеты с неправильной версией.

Мы не предоставляем поддержку Frankensystems. По определению, они нестабильны и подвержены необычным и трудно диагностируемым проблемам. Системы, основанные на Deb, предназначены для работы с конкретными версиями пакетов. Пакеты с неправильной версией вызывают проблемы.

Удалить пакеты неправильной версии. Если вы хотите запустить пакеты 19.04, рассмотрите возможность установки Ubuntu 19.04. Возможно, в виртуальной машине или в свободном разделе, если вы хотите сохранить свою текущую систему 18.04.

0
ответ дан 19 June 2019 в 23:45

Другие вопросы по тегам:

Похожие вопросы: