Обновление Ubuntu 18.04 завершается неудачно; ошибка & ldquo; зависимости пакета не могут быть устранены & rdquo;

Я пытался обновить свой компьютер

Базовая информация о ПК

    description: Notebook
    product: Latitude 7490 (081C)
    vendor: Dell Inc.
    *-cpu
    description: CPU
          product: Intel(R) Core(TM) i7-8650U CPU @ 1.90GHz
    *generic:0
    product: Xeon E3-1200 v5/E3-1500 v5/6th Gen Core Processor Thermal Subsyste
    vendor: Intel Corporation

У меня есть следующие ошибки, которые останавливали Ubuntu для обновления

This error could be caused by required additional software packages which are missing or not installable. Furthermore there could be a conflict between software packages which are not allowed to be installed at the same time.
Transaction failed: Package dependencies cannot be resolved
 The following packages have unmet dependencies:

libgl1:i386: Depends: libc6 (>= 2.4) but 2.27-3ubuntu1 is to be installed
             Depends: libglvnd0 (= 1.0.0-2ubuntu2.3) but 1.0.0-2ubuntu2.3 is to be installed
             Depends: libglx0 (= 1.0.0-2ubuntu2.3) but 1.0.0-2ubuntu2.3 is to be installed

Я пытался сделать

sudo apt update
sudo apt upgrade
sudo apt dist-upgrade

Но получаю следующие ошибки

Reading package lists... Done
Building dependency tree       
Reading state information... Done
Calculating upgrade... Error!
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 g++ : Depends: g++-7 (>= 7.4.0-1~) but it is not going to be installed
 gcc-7 : Depends: libgcc-7-dev (= 7.4.0-1ubuntu1~18.04.1) but it is not going to be installed
 libgl1:i386 : Depends: libglx0:i386 (= 1.0.0-2ubuntu2.3) but it is not going to be installed
E: Error, pkgProblemResolve

Есть предложения по решению проблемы?

Edit0

Результат выполнения sudo apt-get install g++-7 libgcc-7-dev libglx0:i386 && sudo apt-get install g++ gcc-7 libgl1:i386

Reading package lists... Done
Building dependency tree       
Reading state information... Done
g++-7 is already the newest version (7.4.0-1ubuntu1~18.04.1).
libgcc-7-dev is already the newest version (7.4.0-1ubuntu1~18.04.1).
libglx0:i386 is already the newest version (1.0.0-2ubuntu2.3).
0 upgraded, 0 newly installed, 0 to remove and 8 not upgraded.
Reading package lists... Done
Building dependency tree       
Reading state information... Done
g++ is already the newest version (4:7.4.0-1ubuntu2.3).
gcc-7 is already the newest version (7.4.0-1ubuntu1~18.04.1).
libgl1:i386 is already the newest version (1.0.0-2ubuntu2.3).
0 upgraded, 0 newly installed, 0 to remove and 8 not upgraded.

1
задан r0ng 9 July 2019 в 03:03
поделиться