Отсутствие пакетов зависимостей при установке Viber

Для 11.04 и выше

Запустите настройки системы. Либо найдите его в тире или нажмите на шестерню в верхнем правом углу. нажмите «Источники программного обеспечения». Выберите «Обновления», чтобы выбрать, как часто вы хотите проверять наличие обновлений.

Для людей, которые спешат!

Нажмите Alt + F2 и выполните поиск, как показано, и нажмите software-properties-gtk, затем перейдите к шагу 3.

ИЛИ откройте терминал Alt + Alt + F2 и введите software-properties-gtk, затем перейдите к шагу 3.

Используя программное обеспечение Ubuntu center

Если вам удобнее использовать USC, вы можете открыть его и нажать ИЛИ , а затем на нижние источники программного обеспечения. Теперь переходите к шагу 3.

1
задан 1 July 2019 в 22:57

1 ответ

По какой-то причине, как @fkraiem описывает в комментариях , пакет libssl1.0.0 отсутствует в репозитории Ubuntu 19.04 . Вероятно, об этом следует сообщить команде разработчиков Ubuntu как об ошибке. К счастью, есть и хорошие новости: вы можете скачать и установить этот пакет из репозитория 18.10.

Перейдите на страницу загрузки и нажмите ссылку security.ubuntu.com/ubuntu (расположена в середине страницы), после чего начнется диалог установки. После этого вы можете установить Viber.

Все вместе из CLI:

sudo apt update

# download and install the dependencies
wget http://security.ubuntu.com/ubuntu/pool/main/o/openssl1.0/libssl1.0.0_1.0.2n-1ubuntu6.2_amd64.deb
sudo apt install ./libssl1.0.0_1.0.2n-1ubuntu6.2_amd64.deb 

# download and install Viber
wget http://download.cdn.viber.com/cdn/desktop/Linux/viber.deb
sudo apt install ./viber.deb

# just in case
sudo apt install --fix-broken

Оригинальный ответ, который проверен для Ubuntu 16.04 - 18.04 :

Последние несколько Когда я устанавливал Viber, мне нужно было вручную установить некоторые зависимости с помощью опции --fix-broken пакетов apt ... Я просто пытался установить Viber на свежую Ubuntu 18.04 и столкнулся с ошибкой , но это отличается от вашего. Упомянутый подход снова решил проблему. Вот оно:

sudo apt update
wget http://download.cdn.viber.com/cdn/desktop/Linux/viber.deb
sudo dpkg -i viber.deb
sudo apt install -f
0
ответ дан 1 July 2019 в 22:57

Другие вопросы по тегам:

Похожие вопросы: