Ошибка с драйвером Canon imageclass D480 в Ubuntu 12.04 x64

http://www.ubuntu.com/project/about-ubuntu/licensing

Согласно этой ссылке Ubuntu представляет собой набор из нескольких компьютерных программ, и каждый из них может другая лицензия.

Насколько я знаю, базовое ядро ​​Linux выпущено в GNU GPL версии 2:

http://www.ubuntu.com/project / about-ubuntu / licensing

И если вы хотите найти лицензионное соглашение для каждой из этих программ, вы можете найти его на машине Ubuntu в этом месте:

/usr/share/doc/*/copyright

3
задан 8 February 2014 в 22:50

4 ответа

Для Ubuntu 14.04 - x64

Установите следующие файлы в дополнение к драйверам Canon UFR

sudo apt-get install libxml2:i386 libjpeg62:i386 libstdc++6:i386

Благодаря pdc на ubuntuforums.

http://ubuntuforums.org/showthread.php?t=2265278

0
ответ дан 8 February 2014 в 22:50

Похоже, что причиной этой проблемы являются отсутствующие 32-битные библиотеки. Мне пришлось выполнить следующую команду дважды, так как она остановилась в одной точке. Тогда это похоже на работу.

sudo apt-get install libc6-i386 ia32-libs lib32z1

Это решение было найдено в http://ubuntuforums.org/showthread.php?t=1427330&page=10

Я надеюсь, что это поможет кому-то еще, кто борется с драйверами imageclass на 12.04 x64.

0
ответ дан 8 February 2014 в 22:50

Та же проблема для Canon серии 4800 (Canon i-Sensys 4890dw) и Ubuntu 14.04 64bit.

  1. Загрузите «UFRII / UFRII LT Драйвер принтера для Linux v2.80» с веб-сайта canon.
  2. попробуйте установить 32-битные файлы deb: «cndrvcups-common_2.80-1_i386.deb» и «cndrvcups-ufr2-uk_2.80-1_i386.deb»
  3. Менеджер пакетов Ubuntu попытайтесь установить их и загрузите некоторые зависимости, но, наконец, выйдите из процесса установки, не устанавливая их.
  4. попробуйте установить 64-битные файлы deb: «cndrvcups-common_2.80-1_amd64.deb»
  5. ubuntu предупреждают о восстановлении пакета.
  6. нажмите кнопку «восстановить».
  7. попробуйте установить "cndrvcups-ufr2-uk_2.80-1_amd64.deb"
  8. , теперь добавьте принтер.

Я надеюсь, что эта работа для вас.

0
ответ дан 8 February 2014 в 22:50

Подтверждено также в Linux Mint 19 (x86) с драйвером Canon версии 3.60: к сожалению, драйвер связан с версией i386 libxml2. Быстрый ldd на /usr/lib/libcanonufr2.so просто говорит, что libxml2.so.2 не найден (даже если присутствует x64 lib). Установка версии lib38x2 для i386 решает проблему.

0
ответ дан 8 February 2014 в 22:50

Другие вопросы по тегам:

Похожие вопросы: