mod_rewrite включен, но не работает

Согласно wikipedia, Ubuntu по большей части является лицензированным GPL: Единственными исключениями являются некоторые проприетарные аппаратные драйверы. [24] Основной лицензией является GNU General Public License (GNU GPL), которая вместе с GNU Lesser General Public License (GNU LGPL) прямо заявляет, что пользователи могут свободно запускать, копировать, распространять, изучать, изменять, разрабатывать и совершенствовать программного обеспечения. С другой стороны, есть также проприетарное программное обеспечение, которое может работать на Ubuntu.

Источник: http://en.wikipedia.org/wiki/Ubuntu_(operating_system)#Features

Существуют определенные пакеты, которые не включены (например, ограниченные драйверы), которые предоставляют

На официальном http://en.wikipedia.org/wiki/Ubuntu_ (operating_system) #Features вы также можете найти более подробную информацию по этой теме.

Он также явно указывает, что существует 4 типа лицензий, предлагаемых в пакетах ubuntu:

Единственными исключениями являются некоторые проприетарные аппаратные драйверы. [24] Основной лицензией является GNU General Public License (GNU GPL), которая вместе с GNU Lesser General Public License (GNU LGPL) прямо заявляет, что пользователи могут свободно запускать, копировать, распространять, изучать, изменять, разрабатывать и совершенствовать программного обеспечения. С другой стороны, есть также запатентованное программное обеспечение, которое может работать на Ubuntu.

14
задан 17 February 2014 в 14:56

3 ответа

Вы должны разрешить перезапись.

<Directory "/path/to/document/root/">
  AllowOverride All
  Allow from All
</Directory>
0
ответ дан 17 February 2014 в 14:56

Прежде всего, установите для вашей конфигурации httpd следующее (путь может отличаться друг от друга. В моем Ubuntu он находится в / etc / apache2 / sites-available / default):

DocumentRoot /var/www

<Directory /var/www/>
    Options Indexes FollowSymLinks MultiViews
    AllowOverride all
    Order allow,deny
    allow from all
</Directory>

После этого вы должны включить mod_rewrite с помощью этой команды:

sudo a2enmod rewrite

Последняя, ​​, перезапустить службу apache :

sudo service apache2 restart

Чтобы убедиться, что вы можете проверить это снова из phpinfo в Конфигурация> apache2handler> Загруженные модули , там должно быть написано mod_rewrite, и это означает, что mod_rewrite включен.

0
ответ дан 17 February 2014 в 14:56

У меня была похожая проблема, но другие ответы мне не помогли. Эта строка в начале .htaccess решила мою проблему:

Options +FollowSymLinks -MultiViews
0
ответ дан 17 February 2014 в 14:56

Другие вопросы по тегам:

Похожие вопросы: