Как установить ffmpeg 3.0 на Ubuntu 15.10

ffmpeg 3.0 был выпущен в феврале, он решает важную ошибку, поэтому я хочу использовать его.

Есть ли простой способ установить ffmpeg на Ubuntu Wily, например, PPA?

Что я пробовал:

  • Xenial имеет только 2,8,6 , просто как Debian .
  • Статическая сборка на http://johnvansickle.com/ffmpeg/ компилируется без поддержки импульсов, и мне не удалось запустить ее с ALSA
  • PPA https://launchpad.net/~mc3man/+archive/ubuntu/trusty-media предназначен только для Trusty и рекомендует не использовать его для других версий
  • По какой-то причине я попытался скомпилировать из исходного кода результирующие записи ffmpeg в гораздо более низком качестве, видео пикселируются (вывод консоли ).

9
задан 25 March 2016 в 05:49

2 ответа

Я нашел это как рабочее решение для 16,04.

sudo add-apt-repository ppa:jonathonf/ffmpeg-3
sudo apt update
sudo apt upgrade
sudo apt install ffmpeg
[еще 113] информация может быть найдена здесь .

5
ответ дан 25 March 2016 в 15:49
  • 1
    Сначала я сделал подкачку прочь и добавил P9 и P10 к корню. После этого я создал раздел Подкачки. Все хорошо работает, только выйдите, человечность занимает время для начальной загрузки. – data_nerd 26 June 2017 в 16:29

Единственное решение по состоянию на апрель 2016 состоит в том, чтобы скомпилировать собой.

процедура описана в , http://trac.ffmpeg.org/wiki/CompilationGuide/Ubuntu

убедиться выполнить процедуру, описанную в "libx265" абзаце также, не делая ее, привел бы к плохим качественным видеофайлам.

0
ответ дан 25 March 2016 в 15:49
  • 1
    Спасибо, но это просто надевает меня к последним драйверам Nvidia. Я был на Nvidia 381 драйвер, и они были ужасны (я попробовал несколько версий). Какой I' m пытающийся сделать теперь, возвращаются к тому, чем это было, когда я СНАЧАЛА установил Gnome, потому что это работало настолько лучше тогда. – Dorian 26 June 2017 в 08:40

Другие вопросы по тегам:

Похожие вопросы: