Неправильное аудиоустройство по умолчанию

После установки новой копии 19,10, я нашел незначительную неприятность с аудио. У меня есть два устройства, перечисленные под звуковым разделом в gnome-control-center следующим образом:

HDMI / DisplayPort 2 - GP1-4 High Definition Audio Controller
Line Out - Built-in Audio

С предыдущими релизами Ubuntu значение по умолчанию всегда было опцией раздела, которая является той, которую я хочу. Теперь, Это принимает значение по умолчанию к HDMI аудио и отправляет звук через динамики моего монитора.

Выполнение pacmd list short sinks, это показывает следующую информацию о приемниках:

2 sink(s) available.
    index: 0
    name: <alsa_output.pci-0000_00_1f.3.analog-stereo>
    driver: <module-alsa-card.c>
    flags: HARDWARE HW_MUTE_CTRL HW_VOLUME_CTRL DECIBEL_VOLUME LATENCY DYNAMIC_LATENCY
    state: SUSPENDED
    suspend cause: IDLE
    priority: 9039
    volume: front-left: 11796 /  18% / -44.68 dB,   front-right: 11796 /  18% / -44.68 dB
            balance 0.00
    base volume: 65536 / 100% / 0.00 dB
    volume steps: 65537
    muted: no
    current latency: 0.00 ms
    max request: 0 KiB
    max rewind: 0 KiB
    monitor source: 0
    sample spec: s16le 2ch 44100Hz
    channel map: front-left,front-right
                 Stereo
    used by: 0
    linked by: 0
    configured latency: 0.00 ms; range is 0.50 .. 371.52 ms
    card: 0 <alsa_card.pci-0000_00_1f.3>
    module: 7
    properties:
        alsa.resolution_bits = "16"
        device.api = "alsa"
        device.class = "sound"
        alsa.class = "generic"
        alsa.subclass = "generic-mix"
        alsa.name = "ALC892 Analog"
        alsa.id = "ALC892 Analog"
        alsa.subdevice = "0"
        alsa.subdevice_name = "subdevice #0"
        alsa.device = "0"
        alsa.card = "0"
        alsa.card_name = "HDA Intel PCH"
        alsa.long_card_name = "HDA Intel PCH at 0xdd140000 irq 130"
        alsa.driver_name = "snd_hda_intel"
        device.bus_path = "pci-0000:00:1f.3"
        sysfs.path = "/devices/pci0000:00/0000:00:1f.3/sound/card0"
        device.bus = "pci"
        device.vendor.id = "8086"
        device.vendor.name = "Intel Corporation"
        device.product.id = "a170"
        device.product.name = "100 Series/C230 Series Chipset Family HD Audio Controller"
        device.form_factor = "internal"
        device.string = "front:0"
        device.buffering.buffer_size = "65536"
        device.buffering.fragment_size = "32768"
        device.access_mode = "mmap+timer"
        device.profile.name = "analog-stereo"
        device.profile.description = "Analogue Stereo"
        device.description = "Built-in Audio Analogue Stereo"
        alsa.mixer_name = "Realtek ALC892"
        alsa.components = "HDA:10ec0892,18495892,00100302"
        module-udev-detect.discovered = "1"
        device.icon_name = "audio-card-pci"
    ports:
        analog-output-lineout: Line Out (priority 9000, latency offset 0 usec, available: yes)
            properties:

        analog-output-headphones: Headphones (priority 9900, latency offset 0 usec, available: no)
            properties:
                device.icon_name = "audio-headphones"
    active port: <analog-output-lineout>
  * index: 1
    name: <alsa_output.pci-0000_01_00.1.hdmi-stereo-extra1>
    driver: <module-alsa-card.c>
    flags: HARDWARE DECIBEL_VOLUME LATENCY DYNAMIC_LATENCY
    state: SUSPENDED
    suspend cause: IDLE
    priority: 9030
    volume: front-left: 0 /   0% / -inf dB,   front-right: 0 /   0% / -inf dB
            balance 0.00
    base volume: 65536 / 100% / 0.00 dB
    volume steps: 65537
    muted: yes
    current latency: 0.00 ms
    max request: 0 KiB
    max rewind: 0 KiB
    monitor source: 2
    sample spec: s16le 2ch 44100Hz
    channel map: front-left,front-right
                 Stereo
    used by: 0
    linked by: 0
    configured latency: 0.00 ms; range is 0.50 .. 371.52 ms
    card: 1 <alsa_card.pci-0000_01_00.1>
    module: 24
    properties:
        alsa.resolution_bits = "16"
        device.api = "alsa"
        device.class = "sound"
        alsa.class = "generic"
        alsa.subclass = "generic-mix"
        alsa.name = "HDMI 1"
        alsa.id = "HDMI 1"
        alsa.subdevice = "0"
        alsa.subdevice_name = "subdevice #0"
        alsa.device = "7"
        alsa.card = "1"
        alsa.card_name = "HDA NVidia"
        alsa.long_card_name = "HDA NVidia at 0xdf080000 irq 17"
        alsa.driver_name = "snd_hda_intel"
        device.bus_path = "pci-0000:01:00.1"
        sysfs.path = "/devices/pci0000:00/0000:00:01.0/0000:01:00.1/sound/card1"
        device.bus = "pci"
        device.vendor.id = "10de"
        device.vendor.name = "NVIDIA Corporation"
        device.product.id = "10f0"
        device.product.name = "GP104 High Definition Audio Controller"
        device.string = "hdmi:1,1"
        device.buffering.buffer_size = "65536"
        device.buffering.fragment_size = "32768"
        device.access_mode = "mmap+timer"
        device.profile.name = "hdmi-stereo-extra1"
        device.profile.description = "Digital Stereo (HDMI 2)"
        device.description = "GP104 High Definition Audio Controller Digital Stereo (HDMI 2)"
        alsa.mixer_name = "Nvidia GPU 83 HDMI/DP"
        alsa.components = "HDA:10de0083,38425180,00100100"
        module-udev-detect.discovered = "1"
        device.icon_name = "audio-card-pci"
    ports:
        hdmi-output-1: HDMI / DisplayPort 2 (priority 5800, latency offset 0 usec, available: yes)
            properties:
                device.icon_name = "video-display"
    active port: <hdmi-output-1>

Выполнение также pacmd set-default-sink 0 или pacmd set-default-sink 1, затем перезагрузка не имеет никакого значения. Это будет всегда запускать с HDMI аудио как значение по умолчанию.

Что еще я могу попробовать?

4
задан 18 October 2019 в 07:09

2 ответа

У меня была та же проблема после обновления от Ubuntu 19.04 до 19,10. То, что необходимо сделать, является движением к

 /etc/pulse/default.pa

, комментируют

.ifexists module-switch-on-connect.so
load-module module-switch-on-connect
.endif

и перезагрузка.

я надеюсь, что это помогает!

0
ответ дан 17 November 2019 в 05:40

Я имею ту же точную проблему, фиксирую, работает, но это не корректная фиксация IMO При выполнении этого, Вы теперь также прокомментировали автоматическое соединение для гарнитур Bluetooth и т.д., я верю

, прокомментированный раздел

#Use hot-plugged devices like Bluetooth or USB automatically (LP: #1702794)
#Commented after upgrade from 19.04 to stop HDMI which has no speakers attached from stealing audio from Line out
#.ifexists module-switch-on-connect.so
#load-module module-switch-on-connect
#.endif

, Что ссылка LP 1702974 https://bugs.launchpad.net/ubuntu / + source/pulseaudio / + ошибка/1702794

, И это говорит

Этот путь однажды пользователь пары & соединяется устройство беспроводной колонки pulseaudio будет автоматический переключатель к нему.как есть Теперь пользователи должны открыть звуковые настройки & переключитесь вручную. Это достаточно плохо, что автоматический обнаруживают & подключение не работает, (может быть задан сценарием через bluetoothctl), никакой смысл, добавляющий к разочарованию

, Не Похож, мы хотим это, но не хотим мониторы HDMI, которые могут нести аудио на ссылке, но не иметь никакого фактического динамика, присоединенного для взятия канала.

1
ответ дан 17 November 2019 в 05:40

Другие вопросы по тегам:

Похожие вопросы: