Ubuntu 19.10 l2tp VPN больше не работает

После обновления от Ubuntu 19.04 до Ubuntu 19.10 мое соединение VPN больше не работает.

Мои настройки:

phase1: 3des-sha1;modp1024
phase2: 3des-sha1

Это хорошо работало до сих пор.
Я проверил установленные пакеты:

network-manager-l2tp 1.2.10-1; 
network-manager-l2tp-gnome 1.2.10-1; 
xl2tpd 1.3.12-1.1
libreswan 3.29-2

Что я могу сделать?

1
задан 2 November 2019 в 10:53

2 ответа

Попробуйте бэкпорт network-manager-l2tp 1.2.16-1 от следующего PPA:

С network-manager-l2tp 1.2.16-1, необходимо смочь удалить фазу 1 & 2 записи алгоритма, поскольку это теперь использует слияние предложений от Win10 и iOS вместо того, чтобы использовать libreswan или strongswan пакет предложений по умолчанию.

0
ответ дан 7 December 2019 в 18:18

У меня была та же самая проблема при обновлении от 19,04 до 19,10. Я попробовал обновление NetworkManager также, но это не решило мою проблему. Я затем сделал следующие три вещи, и теперь все работает снова:

  1. Замененный libreSwan с StrongSwan (я нашел, произвел ли я чистку libreSwan, StrongSwan был автоматически установлен)
  2. , Явно указал алгоритмы Фазы 1 и Фазы 2: "3des-sha1-modp1024" и "3des-sha1" соответственно.
  3. Обеспеченный только MSCHAPv2 был проверен при Настройках PPP.

у меня есть чувство, что № 3 - то, что решило мою проблему, поскольку я действительно замечал, что еще несколько флажков аутентификации были установлены при Настройках PPP после обновления.

0
ответ дан 7 December 2019 в 18:18

Другие вопросы по тегам:

Похожие вопросы: