Не мог определить местоположение пакета flameshot

Я использую Ubuntu 16.04. Я попытался установить Flameshot, но получил ошибку при высказывании Unable to locate package flameshot .

(base) kong:~$ sudo apt install flameshot
[sudo] password for kong: 
Reading package lists... Done
Building dependency tree       
Reading state information... Done
E: Unable to locate package flameshot

Результаты lsb_release -a :

(base) kong:~$ lsb_release -a
LSB Version:    core-9.20160110ubuntu0.2-amd64:core-9.20160110ubuntu0.2-noarch:printing-9.20160110ubuntu0.2-amd64:printing-9.20160110ubuntu0.2-noarch:security-9.20160110ubuntu0.2-amd64:security-9.20160110ubuntu0.2-noarch
Distributor ID: Ubuntu
Description:    Ubuntu 16.04.6 LTS
Release:    16.04
Codename:   xenial
1
задан 20 November 2019 в 06:08

2 ответа

Если Вы хотите, устанавливают Flameshot на Ubuntu 16.04 , Вы можете просто сборка это из источника .

, Чтобы сделать это, во-первых необходимо установить эти инструменты сборки:

sudo apt install g++ build-essential qt5-default qt5-qmake qttools5-dev-tools
sudo apt install libqt5dbus5 libqt5network5 libqt5core5a libqt5widgets5 libqt5gui5 libqt5svg5-dev
sudo apt install git openssl ca-certificates

И после той загрузки источники и устанавливают их:

git clone https://github.com/lupoDharkael/flameshot.git && cd flameshot
mkdir build && cd build
qmake ../
sudo make
sudo make install
1
ответ дан 3 December 2019 в 07:19

Согласно https://packages.ubuntu.com/search? suite=all&section=all&arch=any&keywords=flameshot&searchon=names

flameshot пакет только доступен для релиза 18.04LTS Ubuntu или позже.

2
ответ дан 3 December 2019 в 07:19

Другие вопросы по тегам:

Похожие вопросы: