Скомпилируйте fcgi драгоценный камень на ubuntu 14.04 LTS

  • ОС: Ubuntu 14.04 LTS
  • Версия Ruby: 2.3.1p112
  • gem -v -> 2.5.1
  • a2enmod fastcgi --> Module fastcgi already enabled
  • Я пытался работать gem install fcgi но это перестало работать с этой ошибкой

    have_header: checking for fastcgi/fcgiapp.h... -------------------- no
    
    "gcc -E -I/usr/local/include/ruby-2.3.0/x86_64-linux -I/usr/local/include/ruby-2.3.0/ruby/backward -I/usr/local/include/ruby-2.3.0 -I.     -O3 -fno-fast-math -ggdb3 -Wall -Wextra -Wno-unused-parameter -Wno-pare$conftest.c:3:29: fatal error: fastcgi/fcgiapp.h: No such file or directory
     #include 
                                 ^
    compilation terminated.
    checked program was:
    /* begin */
    1: #include "ruby.h"
    2:
    3: #include 
    /* end */
    

    Существует ли зависимость, которую я пропускаю? страница Github для драгоценного камня не полезна вообще, так как связь на "НАБОР DEV CGI" разорвана.

0
задан 13 September 2016 в 16:56

1 ответ

Библиотеки потребовали для компиляции драгоценного камня успешно:

sudo apt-get install libfcgi libfcgi-dev

0
ответ дан 28 September 2019 в 14:15

Другие вопросы по тегам:

Похожие вопросы: