склонный - получают установку общая для nfs определенная версия

Короткий вопрос: у Меня есть причина установить определенную версию nfs-common на новой машине. Я хочу установить 1:1.2.8-6ubuntu1.1. Я полагаю, что я должен sudo apt-get install nfs-common, но я не уверен, как указать версию. Я попробовал очевидный из:

$ sudo apt-get install nfs-common=1:1.2.8-6ubuntu1.1
E: Version '1:1.2.8-6ubuntu1.1' for 'nfs-common' was not found

Долгий вопрос: я пытаюсь установить nfs-common по изображению докера. При первой попытке я просто сделал apt-get install nfs-common. Это перестало работать, по-видимому, потому что:

Проблема является настолько общей для nfs, был обновлен в бэкпортах repo, но portmap не имеет, и новые общие для nfs и старые portmap не совместимы. Таким образом для установки это или отключает бэкпорты или применяет силу версия для установки предыдущей версии общих для nfs.

— Источник: Crunchbang.org: [РЕШЕННЫЙ] отказ установки nfs.

Хорошо, я рад вызвать предыдущую версию nfs-common. Это соответствовало бы другой машине, которая была установкой несколько месяцев назад, по-видимому, прежде чем последняя версия была доступна. Движение к той машине и выполнению apt-cache policy nfs-common, Я вижу, что это установило 1:1.2.8-6ubuntu1.1. Рассмотрение страниц справочника для него и:

  1. Как установить определенную версию некоторого пакета?
  2. Как установить определенные пакеты Ubuntu с точной версией?

Я вижу, что должен сделать что-то как apt-get install nfs-common=1:1.2.8-6ubuntu1.1. Однако я не могу выяснить точный синтаксис. Когда я попробовал вышеупомянутое, я получил E: Version '1:1.2.8-6ubuntu1.1' for 'nfs-common' was not found. Я получил ту же ошибку, если я использовал 1:1.2.8-6ubuntu1.2, который является версией по умолчанию, это установлено.

Очевидно, я не понимаю что-то о версии, указанной, и я, может казаться, не нахожу примеров в сети для установки определенной версии общих для nfs (или некоторый компонент, который я могу отобразить на установку старого общего для nfs).

Любая справка ценилась бы.

Дополнительное примечание: Я пытался следовать совету на Пользовательских Форумах Debian: общие для nfs и dpkg ошибки. Я должен был добавить apt-get update. Однако выполнение apt-get install nfs-common законченный сбой с

dpkg: error processing package nfs-common (--configure):
 subprocess installed post-installation script returned error exit status 10
Processing triggers for libc-bin (2.19-0ubuntu6) ...
Processing triggers for ureadahead (0.100.0-16) ...
Errors were encountered while processing:
 nfs-common
E: Sub-process /usr/bin/dpkg returned an error code (1)

2
задан 10 November 2019 в 20:46

1 ответ

Здесь можно загрузить пакет в .deb. Другое решение состоит в том, чтобы установить через Кв. - получают самую близкую более низкую версию, которая доступна, т.е. 1:1.2.8-6ubuntu1.1, если это сделало бы.

РЕДАКТИРОВАНИЕ 1

, который Это устанавливает легко также, по крайней мере, от 1:1.2.8-6ubuntu1.1 в случае, если это не делает.

enter image description here

РЕДАКТИРОВАНИЕ 2

, Но необходимо провериться, если оно работает хорошо. Вы будете во всяком случае:-).

0
ответ дан 2 December 2019 в 23:33

Другие вопросы по тегам:

Похожие вопросы: