Kodi неудавшаяся установка на Ubuntu 16.04 [дубликат]

Этот вопрос уже имеет ответ здесь:

Когда я пытаюсь установить Kodi, я добираюсь:

root@xKaganovich:/home/kaganovich# apt-get install kodi
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following packages were automatically installed and are no longer required:
  fonts-roboto fonts-roboto-hinted kodi-data libcec-platform1v5 libcec3
  libfstrcmp0 libhdhomerun2 libjs-iscroll libsdl2-2.0-0 libsndio6.1
Use 'sudo apt autoremove' to remove them.
Suggested packages:
  kodi-pvr-mythtv kodi-pvr-vuplus kodi-pvr-vdr-vnsi kodi-pvr-njoy
  kodi-pvr-nextpvr kodi-pvr-mediaportal-tvserver kodi-pvr-tvheadend-hts
  kodi-pvr-dvbviewer kodi-pvr-argustv kodi-pvr-iptvsimple
  kodi-audioencoder-vorbis kodi-audioencoder-flac kodi-audioencoder-lame
The following NEW packages will be installed:
  kodi
0 upgraded, 1 newly installed, 0 to remove and 1 not upgraded.
Need to get 0 B/20.0 MB of archives.
After this operation, 37.1 MB of additional disk space will be used.
(Reading database ... 264739 files and directories currently installed.)
Preparing to unpack .../kodi_2%3a17.6+git20171114.2125-final-0xenial_all.deb ...
Unpacking kodi (2:17.6+git20171114.2125-final-0xenial) ...
dpkg: error processing archive /var/cache/apt/archives/kodi_2%3a17.6+git20171114.2125-final-0xenial_all.deb (--unpack):
 trying to overwrite '/usr/share/kodi/media/icon32x32.png', which is also in package kodi-data 15.2+dfsg1-3ubuntu1.1
dpkg-deb: error: subprocess paste was killed by signal (Broken pipe)
Processing triggers for man-db (2.7.5-1) ...
Processing triggers for menu (2.1.47ubuntu1.16.04.1) ...
Errors were encountered while processing:
 /var/cache/apt/archives/kodi_2%3a17.6+git20171114.2125-final-0xenial_all.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

Как я могу решить эту проблему?

0
задан 26 June 2019 в 01:55

1 ответ

У Вас есть конфликт файла. Два пакета пытаются обеспечить тот же файл, и это не позволяется в находящейся в Debian системе.

Пакеты kodi 2:17.6+git20171114.2125-final-0xenial и kodi-data 15.2+dfsg1-3ubuntu1.1 конфликт. Они не могут быть установлены одновременно. Это обычно происходит, когда пакеты из других источников.

Существует два способа разрешить проблему.

1) Выберите пакет, который Вы хотите сохранить, удалить ВСЕ пакеты из отклоненного источника и удалить отклоненный источник. Хранение пакетов из отклоненного источника может вызвать конфликты версий или больше конфликтов файла.

2) Используйте Кв. --force флаг для согласия на перезапись файла. Это решает проблему на сегодняшний день, но проблема может повторяться каждый раз, когда пакеты обновлены.

Простой способ предотвратить эту проблему путем ограничения источников не-Ubuntu, удаления экспериментальных источников после неудачных попыток и иногда использования apt autoremove убрать осиротевшие пакеты от Вашей системы.

0
ответ дан 27 October 2019 в 08:00

Другие вопросы по тегам:

Похожие вопросы: