Не мог обновить сервер Ubuntu

У меня есть VPS под управлением Ubuntu 16.04.5 LTS и до недавнего времени, я не испытал никаких затруднений при обновлении его. Теперь, когда я пробую, я получаю следующее сообщение об ошибке:

The following packages have unmet dependencies:  
linux-headers-4.4.0-134-generic : Depends: linux-headers-4.4.0-134 but it is not installed 
linux-image-virtual : Depends: linux-image-

Это, кажется, произошло в то же самое время, когда следующее сообщение появилось, когда я вхожу в свой VPS:

New release '18.04.1 LTS' available.
Run 'do-release-upgrade' to upgrade to it.

У меня есть несколько веб-сайтов, размещенных на моем VPS, таким образом, я хотел бы держать ОС в курсе с последними обновлениями системы защиты. Как я исправляю это сообщение об ошибке и обновляю мою ОС?

Спасибо.

0
задан 15 September 2018 в 11:37

1 ответ

Вы не встретили зависимости.

Возможной причиной невстреченных зависимостей могла быть поврежденная база данных пакета, и пакеты не были установлены правильно. Попробуйте к trun следующие команды для фиксации:

sudo apt-get clean

и

sudo apt-get autoclean

Использование зависимостей от твердости:

sudo apt-get -f install

-f опция, "фиксируют поврежденный". apt попытается исправить поврежденные зависимости.

Затем выполненный:

sudo dpkg --configure -a

Наконец выполнение снова:

sudo apt-get -f install

1
ответ дан 27 October 2019 в 23:17

Другие вопросы по тегам:

Похожие вопросы: