Проблема зависимости об установке gstreamer на Ubuntu 18.04 [дубликат]

Этот вопрос уже имеет ответ здесь:

Я недавно обновил до Ubuntu 18.04, и DVD-плеер прекратил работать. После некоторого исследования я пытался переустановить gstreamer, но я столкнулся с проблемой, которая кажется связанной с Ubuntu 18.04, и это вне моего понимания. Вот вывод команды:

$ sudo apt-get install gstreamer1.0-tools gstreamer1.0-alsa gstreamer1.0-plugins-base gstreamer1.0-plugins-good gstreamer1.0-plugins-bad gstreamer1.0-plugins-ugly gstreamer1.0-libav
Reading package lists... Done
Building dependency tree      
Reading state information... Done
gstreamer1.0-plugins-base is already the newest version (1.14.1-1ubuntu1~ubuntu18.04.1).
gstreamer1.0-plugins-base set to manually installed.
gstreamer1.0-libav is already the newest version (1.14.1-1~ubuntu18.04.1).
gstreamer1.0-tools is already the newest version (1.14.1-1~ubuntu18.04.1).
gstreamer1.0-tools set to manually installed.
gstreamer1.0-plugins-ugly is already the newest version (1.14.1-1~ubuntu18.04.1).
gstreamer1.0-plugins-good is already the newest version (1.14.1-1ubuntu1~ubuntu18.04.1).
gstreamer1.0-plugins-good set to manually installed.
gstreamer1.0-alsa is already the newest version (1.14.1-1ubuntu1~ubuntu18.04.1).
gstreamer1.0-alsa set to manually installed.
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 gstreamer1.0-plugins-bad : Depends: libgstreamer-plugins-bad1.0-0 (= 1.14.0-1ubuntu1) but 1.14.1-1ubuntu1~ubuntu18.04.1 is to be installed
E: Unable to correct problems, you have held broken packages.

Любая справка действительно ценится (в особенности детьми :))

2
задан 17 November 2019 в 20:55

1 ответ

У меня была некоторая борьба с ним также, но я нашел .deb пакет, который решил проблему:

От https://launchpad.net / ~ ci-train-ppa-service / + archive/ubuntu/3267-deletedppa / + сборка/14926540 загружают

gstreamer1.0-plugins-bad_1.14.1-1ubuntu1~ubuntu18.04.1_amd64.deb

и установите его.

3
ответ дан 2 December 2019 в 02:42

Другие вопросы по тегам:

Похожие вопросы: