не мог установить jscoverage в человечности 16.04, но это работает в 14,04

Я не могу установить jscoverage в 16,04, но способный установить в 14,04

$ sudo apt-get install jscoverage 

Reading package lists... Done
Building dependency tree       
Reading state information... Done  
E: Unable to locate package jscoverage  

Примечание:: jscoverage_0.5.1-2_amd64.deb не был там в 16,04, но в 14,04 Вы поддерживающий jscoverage в 16,04 версиях или не Спасибо, sekharK.

1
задан 24 August 2018 в 14:11

1 ответ

Нет такого пакета на 16.04 LTS и 18.04 репозиториях LTS:

Посмотрите результаты поиска списка на packages.ubuntu.com:

Пакет jscoverage
надежный человек (14.04LTS) (дьявол): покрытие кода JavaScript [вселенная]
0.5.1-2: amd64 arm64 armhf i386 powerpc ppc64el

Но можно установить этот пакет вручную:

wget http://mirrors.kernel.org/ubuntu/pool/universe/j/jscoverage/jscoverage_0.5.1-2_amd64.deb
sudo apt-get install ./jscoverage_0.5.1-2_amd64.deb

Затем можно использовать его

$ jscoverage --version
jscoverage 0.5.1
Character encoding support: iconv
Copyright (C) 2010 siliconforks.com
License GPLv2+: GNU GPL version 2 or later <http://siliconforks.com/jscoverage/license.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.

Я сообщил об ошибке 1788836 к LaunchPad о пропущенных пакетах на 16.04 LTS и 18.04 LTS. Домашняя страница проекта говорит, что от проекта отказываются:

Примечание: Любая будущая разработка кодовой базы JSCoverage, вероятно, произойдет в новом проекте JSCover на GitHub, который снова использует значительный объем кода JSCoverage и стремится к высокой степени обратной совместимости с JSCoverage. Сам JSCoverage вряд ли будет иметь дальнейшие выпуски.

Таким образом, это было отброшено от Debian и затем из Ubuntu.

0
ответ дан 7 December 2019 в 23:38

Другие вопросы по тегам:

Похожие вопросы: