Пакет доступен на packages.ubuntu.com, но не в Ubuntu, использующей склонный

Я хочу установить пакет libc6-dev-amd64 на Ubuntu 18.04, но apt говорит, что нет такого пакета:

sudo apt install libc6-dev-amd64
Reading package lists... Done
Building dependency tree       
Reading state information... Done
E: Unable to locate package libc6-dev-amd64

Также пробуя сбоями архитектуры (это не должно требоваться):

sudo apt install libc6-dev-amd64:i386
Reading package lists... Done
Building dependency tree       
Reading state information... Done
E: Unable to locate package libc6-dev-amd64:i386

Когда я ищу libc6-dev-amd64 в https://packages.ubuntu.com/это ясно показывает, что этот пакет доступен: https://packages.ubuntu.com/search? keywords=libc6-dev-amd64&searchon=names&suite=bionic&section=all.

Почему не делает apt знать об этом?

-1
задан 24 August 2018 в 00:08

1 ответ

Необходимо включить внешнюю дугу - i386:

$ sudo dpkg --add-architecture i386
$ sudo apt update

Затем можно запустить установку:

$ sudo apt install libc6-dev-amd64:i386

или просто

$ sudo apt install libc6-dev-amd64

Поскольку только один пакет "libc6-dev-amd64:i386".

1
ответ дан 28 October 2019 в 02:25

Другие вопросы по тегам:

Похожие вопросы: