gdlib-сконфигурируйте Ubuntu 16.04 / Ubuntu 18.04

Извините за перекрестную рассылку (https://stackoverflow.com/questions/52036228/gdlib-config-ubuntu-16-04-ubuntu-18-04), но я думаю, что она соответствует лучше здесь.

Я нахожусь на использовании Хоста W10 VirtualBox. Я настроил две виртуальных среды: Ubuntu 16.04 и Ubuntu 18.04.

Я пытаюсь установить модуль жемчуга GD. Для этого мне нужен gdlib-файл-конфигурации.

Я могу получить его с Ubuntu 16.04 с помощью следующего:

$whereis gdlib-config
gdlib-config:
$sudo apt-get install libgd-dev
$whereis gdlib-config
gdlib-config: /usr/bin/gdlib-config /usr/share/man/man1/gdlib-config.1.gz

Те же командные строки в соответствии с Ubuntu 18.04:

$whereis gdlib-config
gdlib-config:
$sudo apt-get install libgd-dev
$whereis gdlib-config
gdlib-config:

Оба libgd-dev установки заканчивают успешно

Где я могу получить gdlib-конфигурацию для Ubuntu 18.04? Почему они удаляли gdlib-файл-конфигурации из libgd-dev библиотеки?

Спасибо

0
задан 27 August 2018 в 04:10

1 ответ

На Ubuntu 18.04, с GD-2.56, отбрасывают устаревшее предупреждение проверки опцией --ignore_missing_gd работал бы после установки libgd библиотеки с apt.

т.е.

sudo apt install libgd-dev libgd-perl
perl Makefile.PL --ignore_missing_gd
0
ответ дан 28 October 2019 в 02:04

Другие вопросы по тегам:

Похожие вопросы: