Настройка геймпада Logitech F310 игнорируется играми

Я установил logitech F310 геймпад в соответствии с этим сайтом.

Выглядит нормально, когда я запускаю jstest-gtk, но когда я запускаю игру Xonotic, геймпад игнорируется.

Я попытался:

export SDL_JOYSTICK_DEVICE=/dev/input/js0

, а затем запустить в том же окне терминала

./xonotic-linux-sdl.sh

, который не помог

Я установил:

> sudo chmod 777 /dev/input/js0
> ls -la /dev/input/js0
> crwxrwxrwx+ 1 root input 13, 0 Oct 14 15:57 /dev/input/js0

2
задан 14 October 2019 в 17:03

1 ответ

У меня есть тот же F310, и он работает с Xonotic 0.8.2 (загруженный с веб-сайта) на Ubuntu 18.04 после включения установки маркированное использование joysyik вход на другом разделе по входной установке. Также джойстик должен быть в "X" положение.

Я надеюсь, что это решает Вашу проблему

P.S. Отображение джойстика по умолчанию, кажется, является странным

Input setting

2
ответ дан 2 December 2019 в 03:26

Другие вопросы по тегам:

Похожие вопросы: