Исключение в операции с плавающей запятой (выведенное ядро) при открытии Packet Tracer

Я установил пакетный трассировщик Cisco на человечности 18.04 с помощью этой ссылки. Это работает превосходное над "Гостевой сессией", но не входит в мою учетную запись Cisco. Это бросает эту ошибку каждый раз, когда я пытаюсь войти в систему, и просит вызывать выход:

./libcrypto.so.1.0.0: no version information available (required by ./PacketTracer7)
Floating point exception (core dumped)
0
задан 18 February 2020 в 22:04

1 ответ

На моей Ubuntu 16.04.6 я нашел ответ путем выполнения:

walt@bat:~(0)$ locate libcrypto.so
/lib/x86_64-linux-gnu/libcrypto.so.1.0.0
...
walt@bat:~(0)$ dpkg -S /lib/x86_64-linux-gnu/libcrypto.so.1.0.0
libssl1.0.0:amd64: /lib/x86_64-linux-gnu/libcrypto.so.1.0.0
walt@bat:~(0)$ apt-cache search libssl1.0.0
libssl1.0.0 - Secure Sockets Layer toolkit - shared libraries
libssl1.0.0-dbg - Secure Sockets Layer toolkit - debug information

YMMV, но похоже, что необходимо установить libssl1.0.0 и libssl1,0,0-dbg.

ИЛИ, если Вам уже установили те пакеты, и, так как PacketTracer жалуется на"./libcrypto.so.1.0.0"(указание на него хочет найти libcrypto.so.1.0.0 в текущем каталоге?), возможно, Вы должны

ln -s /lib/x86_64-linux-gnu/libcrypto.so.1.0.0 .

(или везде, где locate сказанный Вас Ваш libcrypto ).

0
ответ дан 20 February 2020 в 22:50

Другие вопросы по тегам:

Похожие вопросы: