Как создать виртуальный хост в апаче с IP-адресом

Я создал виртуальный хост с помощью апача в человечности для моего сайта Wordpress. Я отключил апачские серверы страницы по умолчанию и включил мой сайт, но сайт по умолчанию все еще отображен вместо моего сайта. Что могло быть неправильным?

ОБРАТИТЕ ВНИМАНИЕ, что я использовал IP-адрес вместо servername/xxxx.com. Это может быть причиной?Спасибо

<virtualHost *:80>
  ServerAdmin webmaster@localhost
  ServerName  xx.xx.90.xx

  DocumentRoot /var/www/wordpress
  ErrorLog ${APACHE_LOG_DIR}/error.log
  CustomLog ${APACHE_LOG_DIR}/access.log combined

 <Directory /var/www/wordpress>
     Options -Indexes
 </Directory>

 <IfModule mod_dir.c>
   DirectoryIndex index.php index.html index.cgi
 </IfModule>

<virtualHost/>
0
задан 7 March 2020 в 01:48

1 ответ

Стоит проверить, что сайт по умолчанию на самом деле отключен. Вы не заявили, какую версию Ubuntu Вы используете, но в большинстве версий, версии Ubuntu Apache идут со строками:

# Include generic snippets of statements
IncludeOptional conf-enabled/*.conf

# Include the virtual host configurations:
IncludeOptional sites-enabled/*.conf

внутри /etc/apache2/apache2.conf. Удостоверьтесь, что те строки находятся в, или Apache не будет знать для взгляда в той папке для ее конфигураций. Если Вы перечисляете содержание:

ls /etc/apache2/sites-enabled/

Если Вы использовали автономную конфигурацию для своего virtualhost в /etc/apache2/sites-available необходимо только иметь в наличии сайт там а не сайт по умолчанию.

Также стоит использовать Ваше доменное имя, а не Ваш IP-адрес, как уже упомянуто. Можно, в какой-то момент, хотеть разместить другое содержание в том сервере.

Если это будет единственным виртуальным хостом, то Вы будете иметь, можно обойтись без ServerName строка. Попытайтесь комментировать его (поместите a # в начале строки).

Наконец, после проверки, что у Вас есть только виртуальные хосты, в которых Вы хотите /etc/apache2/sites-enabled, Apache перезапуска для загрузки новых конфигураций:

sudo systemctl restart apache2

Ваша новая конфигурация не загрузится, пока Вы не сделаете так.

Ошибка о www-browser является странным. Как Вы устанавливали Apache? Это означает, что нет никакого установленного браузера командной строки. Вы могли установить Lynx, и это должно зафиксировать его (sudo apt install Lynx), но я сомнителен, что это - причина страницы по умолчанию, показываемой вместо Вашего собственного. Снова, после любого изменения, перезагрузите Apache с sudo systemctl restart apache2.

0
ответ дан 17 March 2020 в 00:06

Другие вопросы по тегам:

Похожие вопросы: