Свежая установка Ubuntu 20.04 не загружается после GRUB и застревает в цикле загрузки [duplicate]

Моя Ubuntu остановилась во время работы Android-версии VirtualBox, поэтому я выключил систему.

Но после сброса он остановился во время этой строки:

Остановка диспетчера пользователей для UID 121 ... _

Поэтому я погуглил его, прочитал этот вопрос и попробовал следующие шаги:

Загрузитесь в режим восстановления, перейдите в корневую оболочку и выполните шаги

ниже: Запустите mount -o rw, remount /, чтобы смонтировать диск в режиме чтения-записи. Запустите sudo apt-get purge nvidia- *, чтобы очистить драйвер NVIDIA. Вы также может потребоваться очистить xserver-xorg и переустановить его, что требует, чтобы вы включили сеть в Recovery.Reboot. Возможно, вам придется добавьте флаг nouveau.modeset = 0 в GRUB для правильной загрузки (проверьте мои вопросы и ответы) для конкретики). Вы должны выйти за рамки мерцания экрана и быть на рабочем столе.

Но, выполнив этот шаг:

Теперь переустановите драйверы NVIDIA надлежащим образом: sudo apt-get install

1
задан 12 June 2020 в 17:37

1 ответ

Чтобы исправить с живого USB, подключитесь к Интернету из действующей системы и откройте терминал, затем выполните следующие действия:

Выполнить:

sudo fdisk -l

И определить свой корневой раздел. Это может быть что-то вроде / dev / sda1 , затем смонтировать его в / mnt примерно так:

sudo mount /dev/sda1 /mnt/

Затем выполнить:

sudo mount --bind /proc/ /mnt/proc/

Затем выполнить:

sudo mount --bind /sys/ /mnt/sys/

Затем запустить:

sudo mount --bind /dev/ /mnt/dev/

Затем запустите:

sudo cp /etc/resolv.conf /mnt/etc/resolv.conf

Затем запустите:

sudo chroot /mnt/

Теперь вы находитесь в своей исходной системе на жестком диске. Сначала обновите APT следующим образом:

sudo apt update

Затем установите xserver-xorg следующим образом:

sudo apt install xserver-xorg

Затем выполните:

sudo apt purge nvidia-*

Затем выполните:

sudo ubuntu-drivers autoinstall

После завершения выполните:

exit

Затем выполните:

sudo umount /mnt/dev/

Затем запустите:

sudo umount /mnt/sys/

Затем запустите:

sudo umount /mnt/proc/

Затем запустите:

sudo umount /mnt/

Затем перезагрузитесь в исходную систему, это должно быть исправлено

1
ответ дан 19 June 2020 в 21:44

Другие вопросы по тегам:

Похожие вопросы: