Постоянно исправляйте «наушники без проблем со звуком» вместо того, чтобы вручную исправлять их каждый раз, когда вы подключить наушники

Я работаю на Ubuntu 20.04, на Dell XPS 13.

Каждый раз, когда я подключаю наушники, весь звук muted.

Следуя инструкциям в других постах здесь, я делаю alsactl restore , который включает как мои наушники, так и мои встроенные динамики ноутбука. Затем мне нужно пойти в alsamixer , чтобы вручную отключить мои динамики, чтобы я мог фактически получить звук из своих наушников и исключительно из своих наушников. Можно ожидать, что это произойдет автоматически, когда вы подключите наушники.

Как уже упоминалось, в других постах здесь объясняется, как решить эту проблему вручную, выполняя вышеуказанные действия каждый раз, когда вы подключаете наушники. По этой причине я не считаю этот пост дубликатом. Я недавно обновил свой ноутбук с 17.10 по 20.04. Одна из особенностей, которые мне понравились, заключалась в том, что я довольно легко ...

Мой предыдущий вопрос был закрыт, но дубликат , на который он указывал, не решил проблему.

Я недавно обновил свой ноутбук с 17.10 по 20.04. Одной из функций, которые мне понравились, было то, что довольно легко я мог отображать в строке меню время с днем, датой и временем, включая секунды. Я попытался установить GNOME Shell Extensions, чтобы я мог установить, например, Clock Override. Но, следуя многочисленным руководствам и установив функции в моем браузере, я могу перейти на extensions.gnome.org, но я получаю ошибку

Не удается найти настройки или версию GNOME Shell. Убедитесь, что он установлен и работает.

Я не могу найти способ обойти это. Я тоже установил

gsettings set org.gnome.desktop.interface clock-show-seconds true

уже был установлен в true - подтверждено как с помощью dconf , так и gsettings get .

Я также посмотрел на инструмент Tweak, но у него не было предложенных настроек.

Итак, в общем, мои часы в данный момент показывают, например, «09:55». То, что я хотел бы (как я сделал 17.10), чтобы это было показано, например, "Вт, 6 июля 09:55". К сожалению, этого я не могу достичь!

Некоторая информация:

  • chrome-gnome-shell была установлена ​​без особой разницы в воскресенье (я думаю!) - следуя руководству по настройке часов на работу.

  • echo $ XDG_CURRENT_DESKTOP дал

     флэшбэк GNOME: GNOME мои часы в настоящее время показывают, например, "09:55". То, что я хотел бы (как я сделал 17.10), чтобы это было показано, например, "Вт, 6 июля 09:55". К сожалению, этого я не могу достичь! 
    

    Некоторая информация:

    • chrome-gnome-shell была установлена ​​без особой разницы в воскресенье (я думаю!) - следуя руководству по настройке часов на работу.

    • echo $ XDG_CURRENT_DESKTOP дал

       флэшбэк GNOME: GNOME мои часы в настоящее время показывают, например, "09:55". То, что я хотел бы (как я сделал 17.10), чтобы это было показано, например, "Вт, 6 июля 09:55". К сожалению, этого я не могу достичь! 
      

      Некоторая информация:

      • chrome-gnome-shell была установлена ​​без особой разницы в воскресенье (я думаю!) - следуя руководству по настройке часов на работу.

      • echo $ XDG_CURRENT_DESKTOP дал

         флэшбэк GNOME: GNOME
        

        and echo $XDG_SESSION_DESKTOP gave

        gnome-flashback-metacity
        

      Just to be clear (and my apologies if I have caused confusion), but the installation of 20.04 was as though the hard disk had been reformatted. There was no traces of any other OS on the installation so this is as pure an installation as one could get.

      Is the final suggestion to create a new user and see what happens? If so, I can try that after the end of the day.

      Also, I have another laptop with 20.04 and I can try the process on there.

0
задан 7 July 2020 в 17:12

2 ответа

The solutions you have tried are applicable for the standard GNOME 3 session, whereas from the outputs of the echo $XDG_CURRENT_DESKTOP and echo $XDG_SESSION_DESKTOP it is clear that you're in a GNOME Flashback session. So solutions are not applicable.

To switch back to a standard GNOME 3, reboot your computer. Then at the GDM login screen, you should find a cogwheel (⚙️) at the bottom right corner. If you click on the cogwheel you should find an 'Ubuntu' (and 'Ubuntu on Wayland') option. select it and then log in.

0
ответ дан 30 July 2020 в 22:12
gsettings set com.canonical.indicator.datetime show-day true
gsettings set com.canonical.indicator.datetime show-date true
gsettings set com.canonical.indicator.datetime show-seconds true
0
ответ дан 30 July 2020 в 22:12

Другие вопросы по тегам:

Похожие вопросы: