Сломанная система пакетов с использованием Ubuntu 18.04 после запуска средства обновления программного обеспечения

Сломанная система пакетов с использованием Ubuntu 18.04 после запуска средства обновления программного обеспечения

Я запустил средство обновления программного обеспечения из графического интерфейса, и появилась эта ошибка. У меня не включены ни один ppa или репозиторий

Как я могу это исправить?

error

Я также запустил

sudo apt --fix-broken install

useoh@s12s72:~$ sudo apt --fix-broken install
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Correcting dependencies... Done
The following packages were automatically installed and are no longer required:
  libllvm10 libllvm10:i386 linux-gcp-5.3-tools-5.3.0-1026 linux-gcp-5.3-tools-5.3.0-1029
Use 'sudo apt autoremove' to remove them.
The following additional packages will be installed:
  linux-image-4.15.0-111-generic
Suggested packages:
  fdutils linux-doc-4.15.0 | linux-source-4.15.0 linux-headers-4.15.0-111-generic
The following NEW packages will be installed:
  linux-image-4.15.0-111-generic
0 upgraded, 1 newly installed, 0 to remove and 22 not upgraded.
2 not fully installed or removed.
Need to get 0 B/8,008 kB of archives.
After this operation, 8,411 kB of additional disk space will be used.
Do you want to continue? [Y/n] y
(Reading database ... 972697 files and directories currently installed.)
Preparing to unpack .../linux-image-4.15.0-111-generic_4.15.0-111.112_amd64.deb ...
Unpacking linux-image-4.15.0-111-generic (4.15.0-111.112) ...
dpkg-deb (subprocess): decompressing archive member: lzma error: compressed data is corrupt
dpkg-deb: error:  subprocess returned error exit status 2
dpkg: error processing archive /var/cache/apt/archives/linux-image-4.15.0-111-generic_4.15.0-111.112_amd64.deb (--unpack):
 dpkg-deb --fsys-tarfile subprocess returned error exit status 2
Errors were encountered while processing:
 /var/cache/apt/archives/linux-image-4.15.0-111-generic_4.15.0-111.112_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

0
задан 14 July 2020 в 05:37

1 ответ

It's right there in your output: A corrupt package.

    Unpacking linux-image-4.15.0-111-generic (4.15.0-111.112) ...
    dpkg-deb (subprocess): decompressing archive member: lzma error: compressed data is corrupt
  1. Delete the corrupt package from your archive:

    sudo apt clean linux-image-4.15.0-111-generic
    
  2. Re-download the correct package:

    sudo apt upgrade
    
2
ответ дан 30 July 2020 в 22:08

Другие вопросы по тегам:

Похожие вопросы: