Error with installing pygame [duplicate]

When I type import pygame in Thonny I get an error. I installed pygame with sudo apt-get install python-pygame, but it's not working. Can somebody help?

0
задан 10 July 2020 в 10:03

1 ответ

Скорее всего, у вас есть python3 в качестве версии по умолчанию для Python, в то время как установленная вами библиотека python предназначена для python2

Вы можете проверить это, выполнив:

python --version

, если у вас нет python2:

apt-get установить python2.7

затем явно запустить python2.7 и запустить импорт pygame оттуда

1
ответ дан 30 July 2020 в 22:11

Другие вопросы по тегам:

Похожие вопросы: