Как установить определенный драйвер nvidia, например, nvidia-driver-440_440.33.01.deb?

Эта страница https://developer.download.nvidia.cn/compute/cuda/repos/ubuntu1804 / x86_64 / перечисляет множество драйверов.

Мне нужно установить версию nvidia-driver-440_440.33.01-0ubuntu1_amd64.deb , потому что мой dmesg говорит:

NVRM: API mismatch: the client has the version 440.33, but
NVRM: this kernel module has the version 440.100.  Please
NVRM: make sure that this kernel module and all NVIDIA driver
NVRM: components have the same version.

после запуска

docker run --gpus all nvidia/cuda:10.0-base nvidia-smi

Итак, мне нужна конкретная версия 440.33

Я попытался загрузить и установить:

sudo apt install -y ./nvidia-driver-440_440.33.01-0ubuntu1_amd64.deb 
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Note, selecting 'nvidia-driver-440' instead of './nvidia-driver-440_440.33.01-0ubuntu1_amd64.deb'
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 nvidia-driver-440 : Depends: libnvidia-gl-440 (= 440.33.01-0ubuntu1) but 440.100-0ubuntu0.20.04.1 is to be installed
                     Depends: nvidia-dkms-440 (= 440.33.01-0ubuntu1)
                     Depends: nvidia-kernel-source-440 (= 440.33.01-0ubuntu1) but it is not going to be installed
                     Depends: libnvidia-compute-440 (= 440.33.01-0ubuntu1) but 440.100-0ubuntu0.20.04.1 is to be installed
                     Depends: nvidia-compute-utils-440 (= 440.33.01-0ubuntu1) but it is not going to be installed
                     Depends: libnvidia-decode-440 (= 440.33.01-0ubuntu1) but 440.100-0ubuntu0.20.04.1 is to be installed
                     Depends: libnvidia-encode-440 (= 440.33.01-0ubuntu1) but 440.100-0ubuntu0.20.04.1 is to be installed
                     Depends: nvidia-utils-440 (= 440.33.01-0ubuntu1) but it is not going to be installed
                     Depends: xserver-xorg-video-nvidia-440 (= 440.33.01-0ubuntu1) but 440.100-0ubuntu0.20.04.1 is to be installed
                     Depends: libnvidia-cfg1-440 (= 440.33.01-0ubuntu1) but 440.100-0ubuntu0.20.04.1 is to be installed
                     Depends: libnvidia-ifr1-440 (= 440.33.01-0ubuntu1) but 440.100-0ubuntu0.20.04.1 is to be installed
                     Depends: libnvidia-fbc1-440 (= 440.33.01-0ubuntu1) but 440.100-0ubuntu0.20.04.1 is to be installed
                     Recommends: nvidia-settings but it is not going to be installed
                     Recommends: nvidia-prime (>= 0.8) but it is not going to be installed
                     Recommends: libnvidia-compute-440:i386 (= 440.33.01-0ubuntu1)
                     Recommends: libnvidia-decode-440:i386 (= 440.33.01-0ubuntu1)
                     Recommends: libnvidia-encode-440:i386 (= 440.33.01-0ubuntu1)
                     Recommends: libnvidia-ifr1-440:i386 (= 440.33.01-0ubuntu1)
                     Recommends: libnvidia-fbc1-440:i386 (= 440.33.01-0ubuntu1)
                     Recommends: libnvidia-gl-440:i386 (= 440.33.01-0ubuntu1)
E: Unable to correct problems, you have held broken packages.

0
задан 18 July 2020 в 09:33

1 ответ

Похоже, что установка пакета вручную вызовет проблемы с зависимостями, и вы можете в конечном итоге нарушить дерево зависимостей.

Я бы предложил вам использовать официальную nvidia ubuntu ppa. Он автоматически установит необходимые зависимости.

 sudo add-apt-repository ppa:graphics-drivers/ppa -y 

 sudo apt update -y 

 sudo apt install nvidia-driver-440 -y 

Если вы используете образ докера для своего приложения, вы можете пересобрать образ докера с определенной версией, чтобы выровнять ее с версией драйвера. Вы можете добавить вышеупомянутые команды в файл Docker и создать образ Docker.

0
ответ дан 30 July 2020 в 22:05

Другие вопросы по тегам:

Похожие вопросы: