4
задан 20 July 2020 в 13:00

1 ответ

There is a extension for Hibernate Button in the Power Menu.

Hibernate gnome-shel Extension

enter image description here

Out of the box there is no effect when you click on the two items, Hibernate and Hybrid Sleep..

If you go to the Extension Homepage link provided on gnome extension website for the Hibernate Extension you will find FAQ part on the README.md

Following the workaround from the FAQ.. copy paste the below content in the file /etc/polkit-1/localauthority/10-vendor.d/com.ubuntu.desktop.pkla

[Enable hibernate in upower]
Identity=unix-user:*
Action=org.freedesktop.upower.hibernate
ResultActive=yes

[Enable hibernate in logind]
Identity=unix-user:*
Action=org.freedesktop.login1.hibernate;org.freedesktop.login1.handle-hibernate-key;org.freedesktop.login1;org.freedesktop.login1.hibernate-multiple-sessions;org.freedesktop.login1.hibernate-ignore-inhibit
ResultActive=yes

Open the file with below command

 sudo -H gedit /etc/polkit-1/localauthority/10-vendor.d/com.ubuntu.desktop.pkla

Copy paste the above content, save the file and close..

Reboot & Test it..

2
ответ дан 30 July 2020 в 22:05

Другие вопросы по тегам:

Похожие вопросы: