ubuntu boot doesn't appear in grub menu

I installed Ubuntu in dual boot with win10. When I tried to remove win10 and be in single boot (Ubuntu), My Grub menu didn't recognize the Ubuntu, and I can't boot into Ubuntu now.

My partition

I can boot into the flashed USB drive that I used to install Ubuntu, so the problem is not in the grub menu. I tried to rub the bot-repair tool, but I got an error: GPT detected. Please create a BIOS-Boot partition (>1MB, unformatted filesystem, bios_grub flag). This can be performed via tools such as Gparted. Then try again.

I also used (parted) print command, and this is the output:

GNU Parted 3.3
Using /dev/sda
Welcome to GNU Parted! Type 'help' to view a list of commands.
(parted) print                                                            
Model: ATA MTFDDAV512TBN-1A (scsi)
Disk /dev/sda: 512GB
Sector size (logical/physical): 512B/4096B
Partition Table: gpt
Disk Flags: 

Number  Start   End    Size   File system  Name  Flags
 6      1049kB  512GB  512GB  ext4               boot, esp

I don't want to reinstall Ubuntu, but I will if it will be the only option.

EDIT: I accidentally deleted EFI system partition...

задан 21 July 2020 в 21:06

1 ответ

From what I can gather, it seems that there was a small partition for grub that contained some data which allowed Ubuntu to be detected. The error message you're getting sounds like somehow this partition was removed, most likely when you removed Windows 10. The question/answer I linked to below talks to this if that's of interest to you.

I can boot into the flashed USB drive that I used to install Ubuntu, so the problem is not in the grub menu.

See if you can bring up the computer's boot menu instead of grub (there are several ways to do this, and they are different for various computers, so you'll likely need to look up this method for your specific computer; however, try pressing esc before the grub menu shows up. This may allow you to see the different bootable drives.

Notice that I have a separate partition for the EFI boot, mounted at /boot/efi

Additionally, I've found a similar, if not exact question that's been answered here before stating that you need to make sure to boot the recovery disk in UEFI mode instead of Legacy/BIOS mode among other things.

Hope this helps!

ответ дан 30 July 2020 в 22:04

Другие вопросы по тегам:

Похожие вопросы: