несколько копий VLC в верхней панели не будут remove [duplicate]

В верхней панели моего Ubuntu 20.04 теперь есть 8 маленьких значков приложений VLC. VLC очень полезен, я не хочу удалять его из моей машины. Он находится в моей панели избранного в нижней части моего экрана, где, опять же, все в порядке.

До сих пор я не мог удалить какие-либо копии значка с верхней панели. Я попытался, щелкнуть правой кнопкой мыши, щелкнуть правой кнопкой мыши Ctrl, клавишей Windows, клавишей Windows и Alt и любыми другими комбинациями, которые я могу придумать. Нет возможности удалить его. Существует вариант выхода, но это не избавляет меня от них.

Также, когда я использую программу «Настройки», уровень громкости отображается семь раз » sudo do-release-upgrade -d Процесс завершается неудачно с сообщением об ошибке ppas, но файлы журнала показывают ...

Я недавно обновился с 16.04 до 18.04.4 LTS, и теперь хочу обновить до 20.04 LTS, используя

sudo do-release-upgrade -d

Процесс завершается ошибкой с сообщением об ошибке ppas, но файлы журнала показывают, что проблема связана с конфликтами ubuntu-standard и lsof. Похоже, что он не может разрешить конфликт между lsof: amd и lsof: i386. Я пытался удалить их и переустановить, но пока ничего не получалось.

Есть ли что-нибудь, что я могу сделать, или я должен подождать и надеяться, что это будет решено сопровождающими пакета?

Starting pkgProblemResolver with broken count: 1
Starting 2 pkgProblemResolver with broken count: 1
Investigating (0) ubuntu-standard:amd64 < 1.417.4 -> 1.450.1 @ii umU Ib >
Broken ubuntu-standard:amd64 Depends on lsof:amd64 < 4.89+dfsg-0.1 | 4.93.2+dfsg-1 @ii ugR >
  Considering lsof:amd64 0 as a solution to ubuntu-standard:amd64 2
  Added lsof:amd64 to the remove list
  Fixing ubuntu-standard:amd64 via keep of lsof:amd64
  MarkKeep lsof:amd64 < 4.89+dfsg-0.1 | 4.93.2+dfsg-1 @ii ugR > FU=0
Investigating (0) lsof:amd64 < 4.89+dfsg-0.1 | 4.93.2+dfsg-1 @ii ugH Ib >
Broken lsof:amd64 Conflicts on lsof:i386 < none -> 4.93.2+dfsg-1 @un umN Ib >
  Considering lsof:i386 4 as a solution to lsof:amd64 0
  Re-Instated lsof:amd64
Investigating (1) lsof:i386 < none -> 4.93.2+dfsg-1 @un umN Ib >
Broken lsof:i386 Conflicts on lsof:amd64 < 4.89+dfsg-0.1 -> 4.93.2+dfsg-1 @ii ugU Ib >
  Considering lsof:amd64 0 as a solution to lsof:i386 4
  Added lsof:amd64 to the remove list
  Conflicts//Breaks against version 4.89+dfsg-0.1 for lsof but that is not InstVer, ignoring
  Fixing lsof:i386 via remove of lsof:amd64
  MarkDelete lsof:amd64 < 4.89+dfsg-0.1 -> 4.93.2+dfsg-1 @ii ugU Ib > FU=0
Investigating (1) ubuntu-standard:amd64 < 1.417.4 -> 1.450.1 @ii umU Ib >
Broken ubuntu-standard:amd64 Depends on lsof:amd64 < 4.89+dfsg-0.1 | 4.93.2+dfsg-1 @ii ugR >
  Considering lsof:amd64 0 as a solution to ubuntu-standard:amd64 2
  Added lsof:amd64 to the remove list
  Fixing ubuntu-standard:amd64 via keep of lsof:amd64
  MarkKeep lsof:amd64 < 4.89+dfsg-0.1 | 4.93.2+dfsg-1 @ii ugR > FU=0
Investigating (1) lsof:amd64 < 4.89+dfsg-0.1 | 4.93.2+dfsg-1 @ii ugH Ib >
Broken lsof:amd64 Conflicts on lsof:i386 < none -> 4.93.2+dfsg-1 @un umN Ib >
  Considering lsof:i386 4 as a solution to lsof:amd64 0
  Removing lsof:amd64 rather than change lsof:i386
  MarkDelete lsof:amd64 < 4.89+dfsg-0.1 | 4.93.2+dfsg-1 @ii ugH Ib > FU=0
Investigating (2) ubuntu-standard:amd64 < 1.417.4 -> 1.450.1 @ii umU Ib >
Broken ubuntu-standard:amd64 Depends on lsof:amd64 < 4.89+dfsg-0.1 | 4.93.2+dfsg-1 @ii ugR >
  Considering lsof:amd64 0 as a solution to ubuntu-standard:amd64 2
  Added lsof:amd64 to the remove list
  Fixing ubuntu-standard:amd64 via keep of lsof:amd64
  MarkKeep lsof:amd64 < 4.89+dfsg-0.1 | 4.93.2+dfsg-1 @ii ugR > FU=0
Investigating (2) lsof:amd64 < 4.89+dfsg-0.1 | 4.93.2+dfsg-1 @ii ugH Ib >
Broken lsof:amd64 Conflicts on lsof:i386 < none -> 4.93.2+dfsg-1 @un umN Ib >
  Considering lsof:i386 4 as a solution to lsof:amd64 2
  Removing lsof:amd64 rather than change lsof:i386
  MarkDelete lsof:amd64 < 4.89+dfsg-0.1 | 4.93.2+dfsg-1 @ii ugH Ib > FU=0
Investigating (3) ubuntu-standard:amd64 < 1.417.4 -> 1.450.1 @ii umU Ib >
Broken ubuntu-standard:amd64 Depends on lsof:amd64 < 4.89+dfsg-0.1 | 4.93.2+dfsg-1 @ii ugR >
  Considering lsof:amd64 4 as a solution to ubuntu-standard:amd64 2
  MarkKeep ubuntu-standard:amd64 < 1.417.4 -> 1.450.1 @ii umU Ib > FU=0
    Reinst Failed because of lsof:amd64
  MarkKeep ubuntu-standard:amd64 < 1.417.4 -> 1.450.1 @ii umU Ib > FU=0
  Removing ubuntu-standard:amd64 rather than change lsof:amd64

...

DEBUG The package 'ubuntu-standard' is marked for removal but it's in the removal blacklist
ERROR Dist-upgrade failed: 'The package 'ubuntu-standard' is marked for removal but it is in the removal blacklist.'

РЕДАКТИРОВАТЬ: по запросу, вот вывод Политика apt-cache Стандарт Ubuntu lsof lsof: i386

ubuntu-standard:
  Installed: 1.417.4
  Candidate: 1.417.4
  Version table:
 *** 1.417.4 500
        500 http://ca.archive.ubuntu.com/ubuntu bionic-updates/main amd64 Packages
        100 /var/lib/dpkg/status
     1.417 500
        500 http://ca.archive.ubuntu.com/ubuntu bionic/main amd64 Packages
lsof:
  Installed: 4.89+dfsg-0.1
  Candidate: 4.89+dfsg-0.1
  Version table:
 *** 4.89+dfsg-0.1 500
        500 http://ca.archive.ubuntu.com/ubuntu bionic/main amd64 Packages
        100 /var/lib/dpkg/status
lsof:i386:
  Installed: (none)
  Candidate: 4.89+dfsg-0.1
  Version table:
     4.89+dfsg-0.1 500
        500 http://ca.archive.ubuntu.com/ubuntu bionic/main i386 Packages

Я также попытался обновить систему до 19.10 в качестве промежуточного шага, но эта же проблема lsof блокирует его. E: У пакета 'curl' нет кандидата для установки Предыдущий вопрос предложил мне переключиться на другое зеркало Ubuntu. Я ...

Я бы хотел установить браузер Brave, но установить curl невозможно.

E: Пакет 'curl' не имеет возможности установки

В предыдущем вопросе предлагалось переключиться на другое зеркало Ubuntu. Я переключился на лучший сервер, но ничего не изменилось.

Reading package lists... Done
Building dependency tree       
Reading state information... Done
Package curl is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

E: Package 'curl' has no installation candidate

Обновление дает следующее:

Hit:1 http://ppa.launchpad.net/micahflee/ppa/ubuntu focal InRelease
Hit:2 http://archive.ubuntu.com/ubuntu focal InRelease
Reading package lists... Done
Building dependency tree       
Reading state information... Done
All packages are up to date.

apt policy ubuntu-desktop

ubuntu-desktop:
  Installed: 1.450.1
  Candidate: 1.450.1
  Version table:
 *** 1.450.1 100
        100 /var/lib/dpkg/status

Kulfy, спасибо. Сначала мне нужно было запустить эти строки, а затем установить

apt remove -y libcurl4
apt install -y libcurl4 curl

Руби, спасибо. В данный момент браузер устанавливается. Я решил проблему на основе этого ответа https://askubuntu.com/a/1051988/1100108 Не уверен, что ваше решение приведет к тому же самому, но все хорошо сейчас.

0
задан 9 July 2020 в 19:07

1 ответ

Это проблема с вашим репозиторием, curl доступен в main Ubuntu. Вам необходимо обновить свой репозиторий. Откройте терминал и запустите

nano /etc/apt/sources.list

Обновите свой репозиторий и запустите

sudo apt-get update
sudo apt-get install curl
1
ответ дан 30 July 2020 в 22:11

Другие вопросы по тегам:

Похожие вопросы: