I installed Ubuntu 18.04.3 LTS on my laptop. I am unable to connect to the Internet by wifi or cable

But after installation I am unable to connect to my modem by ether cable or wifi. I have tried to search for information about this but unable to find anything. I am very new to this and not sure what to do. I have tried ip a but it does not give me a ipv4 address. It also does not recognize enp3s4f1 or enp3s4f0. Also tried sudo ethtool -s enp3s4f1 speed 100 duplex full autoneg off but I get sudo: ethtool: command not found. When I check network under wired it says that the cable is unplug even though it is plugged in. Tried /etc/network/interfaces but got permission denied. Used sudo lshw -C network and it recognized my cable port and wifi card. When I used cat /etc/netplan/*.yaml it said no such file or directory.

I have a COMPAQ Presario CQ56 that I used Ubuntu 14.04 LTS 64 bit at one time and had no problems connecting to the internet with either wifi or cable. This is the same computer that I am trying to get 18.04.3 to run on. After trying ifconfig -a' I am told to use sudo apt install net-tools. When I use sudo apt install net-toolswith my installation disk in cd drive I getPackage net-tools is not available, but is referred to by another package. This may mean that the package is missing, has been obsoleted, or is only available from another source`. Where do I get the package!

задан 25 July 2020 в 20:44

1 ответ

I нашел пакет net-tools и загрузил его на USB. Затем я установил его на свой ноутбук, и теперь он работает на 100% для подключения к Интернету.

ответ дан 30 July 2020 в 22:02

Другие вопросы по тегам:

Похожие вопросы: