Ошибка при установке xsane, sane, hplip и т. Д. С неопределенным символом: ошибка libusb_set_option

Я постоянно получаю эту ошибку,

xsane: symbol lookup error: /usr/lib/x86_64-linux-gnu/libsane.so.1: undefined symbol: libusb_set_option

и эту ошибку,

checking for sane_open in -lsane... no
configure: error: cannot find sane-backends-devel support (or --disable-scan-build)" 
when trying to install hplip-3.20.5

У меня эта проблема с Ubuntu 19, в настоящее время я использую Ubuntu 20.04. Я переустановил libusb-1 , libsane.so.1

Я пытаюсь установить многофункциональный принтер HP 'HP Office jet pro 9018'

Начнем с tl ; dr -

apt-cache policy xsane libsane1 libsane-common libusb-1.0
xsane:
  Installed: 0.999-8ubuntu2
  Candidate: 0.999-8ubuntu2
  Version table:
 *** 0.999-8ubuntu2 500
        500 http://archive.ubuntu.com/ubuntu focal/universe amd64 Packages
        100 /var/lib/dpkg/status
libsane1:
  Installed: 1.0.30+git20200801-focal0
  Candidate: 1.0.30+git20200802-focal0
  Version table:
     1.0.30+git20200802-focal0 500
        500 http://ppa.launchpad.net/rolfbensch/sane-git/ubuntu focal/main amd64 Packages
 *** 1.0.30+git20200801-focal0 100
        100 /var/lib/dpkg/status
     1.0.29-0ubuntu5 500
        500 http://archive.ubuntu.com/ubuntu focal/universe amd64 Packages
libsane-common:
  Installed: 1.0.30+git20200801-focal0
  Candidate: 1.0.30+git20200802-focal0
  Version table:
     1.0.30+git20200802-focal0 500
        500 http://ppa.launchpad.net/rolfbensch/sane-git/ubuntu focal/main amd64 Packages
        500 http://ppa.launchpad.net/rolfbensch/sane-git/ubuntu focal/main i386 Packages
 *** 1.0.30+git20200801-focal0 100
        100 /var/lib/dpkg/status
     1.0.29-0ubuntu5 500
        500 http://archive.ubuntu.com/ubuntu focal/main amd64 Packages
        500 http://archive.ubuntu.com/ubuntu focal/main i386 Packages
libusb-1.0-0:
  Installed: 2:1.0.23-2build1
  Candidate: 2:1.0.23-2build1
  Version table:
 *** 2:1.0.23-2build1 500
        500 htt_://archive.ubuntu.com/ubuntu focal/main amd64 Packages
        100 /var/lib/dpkg/status
libusb-1.0-0-dev:
  Installed: 2:1.0.23-2build1
  Candidate: 2:1.0.23-2build1
  Version table:
 *** 2:1.0.23-2build1 500
        500 htt_://archive.ubuntu.com/ubuntu focal/main amd64 Packages
        100 /var/lib/dpkg/status
libusb-1.0-doc:
  Installed: 2:1.0.23-2build1
  Candidate: 2:1.0.23-2build1
  Version table:
 *** 2:1.0.23-2build1 500
        500 htt_://archive.ubuntu.com/ubuntu focal/main amd64 Packages
        500 htt_://archive.ubuntu.com/ubuntu focal/main i386 Packages
        100 /var/lib/dpkg/status
1
задан 2 August 2020 в 14:31

1 ответ

It looks like you have messed the stuff by using PPAs. Remove them with:

sudo apt-get install ppa-purge
sudo ppa-purge ppa:rolfbensch/sane-git

and then reinstall sane from the official repository by:

sudo apt-get install --reinstall libsane1=1.0.29-0ubuntu5 libsane-common=1.0.29-0ubuntu5

About HPLIP please consider to install it from repository by running:

sudo apt-get install hplip-gui

followed by hp-setup and

hp-plugin

as you may need it to support scanner of your device.

0
ответ дан 2 August 2020 в 22:00

Другие вопросы по тегам:

Похожие вопросы: