Проблемы с мостом netplan Ubuntu 18.04 на VirtualBox

Я застрял здесь в конфигурации сети, и мне нужна помощь ..

Планируется создать KVM с окнами, работающими на выделенном ubuntu 18.04 сервер.

Итак, мне нужен сетевой мост для доступа к окнам в моем Ubuntu. Чтобы опробовать этот проект моста, я создал сервер ubuntu 18.04 в моем виртуальном ящике и попытался настроить там работающий сетевой мост ..

Каждый раз, когда я применяю свою конфигурацию netplan, сетевое соединение перестает работать ..

Я действительно нужна помощь и объяснение, как работает эта магия ... Конечно, я погуглил, но я не нашел объяснения или примера, которые работают или помогли бы мне понять.

Вот рабочий / etc / netplan / 50- cloud-init.yaml - конфигурация из моей ubuntu vm.

network:
  ethernets:
    enp0s3:
    gateway4: 192.168.176.1
    dhcp4: false
    addresses: [192.168.176.40/23]
  version: 2

Теперь я попытался настроить мост:

network:
  version: 2
  renderer: networkd
  ethernets:
    enp0s3:
      dhcp4: false
  bridges:
    br0:
      dhcp4: false
      addresses: [192.168.176.40/23]
      gateway4: 192.168.176.1
      interfaces:
        - enp0s3

Если я запустил ' netplan apply 'сейчас, ssh-соединение с моей виртуальной машиной разорвано, и соединение с Интернетом также не работает ..

Вы можете помочь мне с этой проблемой и объяснить, что мне здесь нужно делать?

Здесь у меня для вас есть 'ifconfig' из конфигурации runnung:

root@vmbuntuerver18:/etc/netplan# ifconfig
enp0s3: flags=4163  mtu 1500
        inet 192.168.176.40  netmask 255.255.254.0  broadcast 192.168.177.255
        inet6 2003:d3:cf20:ce00:a00:27ff:fee9:ad0d  prefixlen 64  scopeid 0x0
        inet6 fe80::a00:27ff:fee9:ad0d  prefixlen 64  scopeid 0x20
        ether 08:00:27:e9:ad:0d  txqueuelen 1000  (Ethernet)
        RX packets 787  bytes 71995 (71.9 KB)
        RX errors 0  dropped 546  overruns 0  frame 0
        TX packets 122  bytes 18977 (18.9 KB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

lo: flags=73  mtu 65536
        inet 127.0.0.1  netmask 255.0.0.0
        inet6 ::1  prefixlen 128  scopeid 0x10
        loop  txqueuelen 1000  (Local Loopback)
        RX packets 92  bytes 7036 (7.0 KB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 92  bytes 7036 (7.0 KB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

А вот 'ifconfig' с моей сломанной конфигурацией моста:

enter image description here

(я не могу скопировать текст, поэтому здесь изображение)

I ' Я благодарен за каждую идею или ответ.

0
задан 10 August 2020 в 15:19

2 ответа

Я мог бы решить свою проблему, включив неразборчивый- режим в настройках виртуальной машины из моего VertualBox.

Моя 'bridged-config' работает.

Вот изображение из моих сетевых настроек VirtualBox: enter image description here

0
ответ дан 11 August 2020 в 20:05

Вам также необходимо применить отступ после строки br0 для моста следующим образом:

network:
  version: 2
  renderer: networkd
  ethernets:
    enp0s3:
      dhcp4: false
  bridges:
    br0:
      dhcp4: false
      addresses: [192.168.176.40/23]
      gateway4: 192.168.176.1
      interfaces:
        - enp0s3
0
ответ дан 11 August 2020 в 20:05

Другие вопросы по тегам:

Похожие вопросы: