Ошибка при установке Wine

Я хочу использовать LTspice на моем Ubuntu 20.04 LTS. Но он не доступен для Ubuntu, поэтому мой профессор предложил мне скачать Wine.

Я сделал все шаги, как упоминалось в https://wiki.winehq.org/Ubuntu.

Однако на последнем шаге, когда я набираю sudo apt install --install-recommends winehq-stable

Я получаю эту ошибку :

Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 winehq-stable : Depends: wine-stable (= 5.0.2~focal)
E: Unable to correct problems, you have held broken packages.

Как я могу это исправить?

0
задан 19 September 2020 в 07:38

3 ответа

Благодаря сообществу я получил ответ.

Вы можете проверить здесь Как мне восстановить репозитории по умолчанию?

0
ответ дан 4 January 2021 в 08:22

Выполните следующие действия:

1. Включите 32-битную архитектуру

sudo dpkg --add-architecture i386

2. Загрузите и установите ключ репозитория

wget -nc https://dl.winehq.org/wine-builds/winehq.key; sudo apt-key add winehq.key

3. Добавьте винный репозиторий

sudo apt-add-repository 'deb https://dl.winehq.org/wine-builds/ubuntu/ focal main'

ПРИМЕЧАНИЕ. Замените focal на eoan для Ubuntu 19.10, bionic для Ubuntu 18.04, xenial для Ubuntu 16.04

4. Добавьте PPA для необходимой библиотеки libfaudio0

sudo add-apt-repository ppa:cybermax-dexter/sdl2-backport

5. Выполните обновление

sudo apt-get update

6. Установите Wine 5.0 стабильный

sudo apt install --install-recommends winehq-stable
0
ответ дан 4 January 2021 в 08:22

Возможно, некоторые пакеты должны быть понижены, если вы перейдете через зависимости, вы увидите что-то вроде «libxxx (версия 20.04ubuntu9) установлена, но требуется (версия 20.04)». Чтобы решить эту проблему в фокусе 20.04LTS, поместите / создайте в файл / etc / apt / preferences :

Package: *
Pin: release a=focal
Pin-Priority: 1001`

выполните:

apt update
apt upgrade
apt install wine-stable

необязательно очистите / etc / apt / preferences и ] подходящее обновление; apt upgrade

0
ответ дан 4 January 2021 в 08:22

Другие вопросы по тегам:

Похожие вопросы: