Нет подключения к Ethernet в Ubuntu Studio 20.04.1 LTS

После последнего обновления Ubuntu Studio 20.04.1 моя настольная система не может получить доступ к карте Ethernet (светодиоды не горят), и у меня нет подключения к Интернету. Последнее установленное ядро ​​в моей системе - 5.4.0-56 с низкой задержкой. Я могу загрузить систему с предыдущим ядром, 5.4.0-54-lowlatency, а затем карта Ethernet работает нормально, и я могу подключиться. Я читал, что эта ошибка могла быть исправлена ​​в ядре 5.4.0.56.62, но я полагаю, что это не проблема с низкой задержкой.

  • Как я могу нормально загрузиться на последней версии ядра и иметь Ethernet работает?
  • Как мне обновить текущее ядро ​​до того, которое исправляет ошибку
    Ошибка Ethernet?

Редактировать 1: Я только что обновил ядро ​​до версии 5.4.0-58-lowlatency, но проблема не исчезла.

Редактировать 2: Эта проблема присутствует в ядрах до версии 5.8.0-33.36. См. Эту ошибку для получения дополнительной информации: https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1906655

Спасибо.

Изменить: вывод dpkg -l | grep linux ниже:

ii  binutils-x86-64-linux-gnu                     2.34-6ubuntu1                          amd64        GNU binary utilities, for x86-64-linux-gnu target
ii  console-setup-linux                           1.194ubuntu3                           all          Linux specific part of console-setup
ii  fonts-linuxlibertine                          5.3.0-4                                all          Linux Libertine family of fonts
ii  ladspa-sdk                                    1.15-2build1                           amd64        sample tools for linux-audio-dev plugin architecture
ii  liblinux-epoll-perl                           0.017-1                                amd64        perl epoll module for O(1) multiplexing
ii  libselinux1:amd64                             3.0-1build2                            amd64        SELinux runtime shared libraries
ii  libselinux1:i386                              3.0-1build2                            i386         SELinux runtime shared libraries
ii  libv4l-0:amd64                                1.18.0-2build1                         amd64        Collection of video4linux support libraries
ii  libv4lconvert0:amd64                          1.18.0-2build1                         amd64        Video4linux frame format conversion library
ii  linux-base                                    4.5ubuntu3.1                           all          Linux image base package
ii  linux-firmware                                1.187.4                                all          Firmware for Linux kernel drivers
ii  linux-headers-5.4.0-54                        5.4.0-54.60                            all          Header files related to Linux kernel version 5.4.0
ii  linux-headers-5.4.0-54-lowlatency             5.4.0-54.60                            amd64        Linux kernel headers for version 5.4.0 on 64 bit x86 SMP
ii  linux-headers-5.4.0-56                        5.4.0-56.62                            all          Header files related to Linux kernel version 5.4.0
ii  linux-headers-5.4.0-56-lowlatency             5.4.0-56.62                            amd64        Linux kernel headers for version 5.4.0 on 64 bit x86 SMP
ii  linux-headers-lowlatency                      5.4.0.56.59                            amd64        lowlatency Linux kernel headers
rc  linux-image-4.15.0-112-lowlatency             4.15.0-112.113                         amd64        Signed kernel image lowlatency
rc  linux-image-4.15.0-115-lowlatency             4.15.0-115.116                         amd64        Signed kernel image lowlatency
rc  linux-image-4.15.0-117-lowlatency             4.15.0-117.118                         amd64        Signed kernel image lowlatency
rc  linux-image-4.15.0-118-lowlatency             4.15.0-118.119                         amd64        Signed kernel image lowlatency
rc  linux-image-5.4.0-48-lowlatency               5.4.0-48.52                            amd64        Signed kernel image lowlatency
rc  linux-image-5.4.0-51-lowlatency               5.4.0-51.56                            amd64        Signed kernel image lowlatency
rc  linux-image-5.4.0-52-lowlatency               5.4.0-52.57                            amd64        Signed kernel image lowlatency
rc  linux-image-5.4.0-53-lowlatency               5.4.0-53.59                            amd64        Signed kernel image lowlatency
ii  linux-image-5.4.0-54-lowlatency               5.4.0-54.60                            amd64        Signed kernel image lowlatency
ii  linux-image-5.4.0-56-lowlatency               5.4.0-56.62                            amd64        Signed kernel image lowlatency
ii  linux-image-lowlatency                        5.4.0.56.59                            amd64        lowlatency Linux kernel image
ii  linux-libc-dev:amd64                          5.4.0-56.62                            amd64        Linux Kernel Headers for development
ii  linux-lowlatency                              5.4.0.56.59                            amd64        Complete lowlatency Linux kernel
rc  linux-modules-4.15.0-112-lowlatency           4.15.0-112.113                         amd64        Linux kernel extra modules for version 4.15.0 on 64 bit x86 SMP
rc  linux-modules-4.15.0-115-lowlatency           4.15.0-115.116                         amd64        Linux kernel extra modules for version 4.15.0 on 64 bit x86 SMP
rc  linux-modules-4.15.0-117-lowlatency           4.15.0-117.118                         amd64        Linux kernel extra modules for version 4.15.0 on 64 bit x86 SMP
rc  linux-modules-4.15.0-118-lowlatency           4.15.0-118.119                         amd64        Linux kernel extra modules for version 4.15.0 on 64 bit x86 SMP
rc  linux-modules-5.4.0-48-lowlatency             5.4.0-48.52                            amd64        Linux kernel extra modules for version 5.4.0 on 64 bit x86 SMP
rc  linux-modules-5.4.0-51-lowlatency             5.4.0-51.56                            amd64        Linux kernel extra modules for version 5.4.0 on 64 bit x86 SMP
rc  linux-modules-5.4.0-52-lowlatency             5.4.0-52.57                            amd64        Linux kernel extra modules for version 5.4.0 on 64 bit x86 SMP
rc  linux-modules-5.4.0-53-lowlatency             5.4.0-53.59                            amd64        Linux kernel extra modules for version 5.4.0 on 64 bit x86 SMP
ii  linux-modules-5.4.0-54-lowlatency             5.4.0-54.60                            amd64        Linux kernel extra modules for version 5.4.0 on 64 bit x86 SMP
ii  linux-modules-5.4.0-56-lowlatency             5.4.0-56.62                            amd64        Linux kernel extra modules for version 5.4.0 on 64 bit x86 SMP
ii  linux-sound-base                              1.0.25+dfsg-0ubuntu5                   all          base package for ALSA and OSS sound systems
ii  pptp-linux                                    1.10.0-1build1                         amd64        Point-to-Point Tunneling Protocol (PPTP) Client
ii  util-linux                                    2.34-0.1ubuntu9.1                      amd64        miscellaneous system utilities
0
задан 13 December 2020 в 03:10

3 ответа

У вас есть проприетарные драйверы?

проверьте, есть ли в вашем /etc/apt/sources.list строка

deb http:/YOURREPOSITORYADRESS YOURUBUTUVERSION main contrib non-free

или

deb http://YOURREPOSITORYADRESS/ubuntu/ YOURUBUNTUVERSION main restricted universe multiverse 

после, дайте нам вывод dmesg -l err

-2
ответ дан 3 January 2021 в 22:47

Я столкнулся с та же проблема: что-то неправильно работает с новейшим ядром с низкой задержкой при использовании сетевой карты Realtek, что вызывает несоответствие irq между картой Ethernet и другими устройствами (в моем случае ahci: вы можете проверить это с помощью "dmesg | хвост "); в моем случае:

[4.636432] genirq: Несоответствие флагов irq 19. 00010080 (enp2s0) vs. 00002080 (ahci [0000: 00: 1f.2])

Я могу использовать сеть, только загрузив файл с низкой задержкой Ядро: для этого удерживайте кнопку Shift сразу после начального экрана BIOS: таким образом вы войдете в меню grub2, выберите «дополнительные параметры», а затем выберите ядро ​​(не с низкой задержкой), которое вы хотите использовать.

Таким образом, я снова могу заниматься серфингом. Недостатки заключаются в том, что:

  • процедура должна выполняться вручную после каждой загрузки
  • функции ядра с низкой задержкой будут недоступны.

Надеюсь, они собираются исправить это как можно скорее!

0
ответ дан 3 January 2021 в 22:47

I нашел решение. Чего не хватало, так это linux-modules-extra-5.4.0-58 -?

Я загрузил Linux с предыдущей версией 5.4.0-54, затем установил linux-modules-extra для последней версии для образ ядра, затем перезагрузитесь. Он работал с моим общим образом ядра.

По какой-то причине, когда я запускал apt upgradeded , дополнительный пакет не устанавливался. Не знаю почему.

0
ответ дан 3 January 2021 в 22:47

Другие вопросы по тегам:

Похожие вопросы: