Невозможно установить OpenJDK в Ubuntu 18.04

Я пробовал несколько способов установить openjdk , и вот что я получаю, когда это делаю: java -version

openjdk version "11.0.4" 2019-07-16
OpenJDK Runtime Environment (build 11.0.4+11-post-Ubuntu-1ubuntu218.04.3)
OpenJDK 64-Bit Server VM (build 11.0.4+11-post-Ubuntu-1ubuntu218.04.3, mixed mode, sharing)

Но когда я выполняю javac -version, он говорит, что javac не может быть найден. Я делаю следующее: sudo apt-get install default-jre

The following packages have unmet dependencies:
 default-jre : Depends: default-jre-headless (= 2:1.10-63ubuntu1~02) but 2:1.11-68ubuntu1~18.04.1 is to be installed
               Depends: openjdk-11-jre but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

Затем: sudo apt-get install default-jdk

default-jdk : Depends: default-jre (= 2:1.10-63ubuntu1~02) but it is not going to be installed
              Depends: default-jdk-headless (= 2:1.10-63ubuntu1~02) but it is not going to be installed
              Depends: openjdk-11-jdk but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

Затем: sudo update-alternatives --config java

Есть 2 варианта альтернативной java (предоставление /usr/bin/java).

  Selection    Path                                            Priority   Status
------------------------------------------------------------
* 0            /usr/lib/jvm/java-11-openjdk-amd64/bin/java      1111      auto mode
  1            /usr/lib/jvm/java-11-openjdk-amd64/bin/java      1111      manual mode
  2            /usr/lib/jvm/java-8-openjdk-amd64/jre/bin/java   1081      manual mode

Как исправить эти проблемы и получить надлежащую установка java и javac?

0
задан 11 December 2020 в 20:11

0 ответов

Другие вопросы по тегам:

Похожие вопросы: