Зачем нужно устанавливать snapd перед установкой стороннего программного обеспечения? [дубликат]

Когда я делаю

apt-get install chromium-browser

, он загружает какой-то файл .deb, а затем устанавливает пакет оснастки:

Selecting previously unselected package chromium-browser.
(Reading database ... 227048 files and directories currently installed.)
Preparing to unpack .../chromium-browser_77.0.3865.120-0ubuntu1~snap1_amd64.deb
...
=> Installing the chromium snap
==> Checking connectivity with the snap store
==> Installing the chromium snap
Warning: /snap/bin was not found in your $PATH. If you've not restarted your
         session since you installed snapd, try doing that. Please see
         https://forum.snapcraft.io/t/9469 for more details.

chromium 78.0.3904.70 from Canonical✓ installed
=> Snap installation complete
Unpacking chromium-browser (77.0.3865.120-0ubuntu1~snap1) ...
Setting up chromium-browser (77.0.3865.120-0ubuntu1~snap1) ...
Processing triggers for mime-support (3.63ubuntu1) ...
Processing triggers for hicolor-icon-theme (0.17-2) ...
Processing triggers for gnome-menus (3.32.0-1ubuntu1) ...
Processing triggers for desktop-file-utils (0.24-1ubuntu1) ...
(base) keddad@keddad:~$

Но я не просил его доставить мне хром через оснастку, я хотел получить нормальный. deb пакет. В конце концов, это работает, но кажется неправильным. Если я хочу получить снимок, я использую snap , а не apt . Почему такое поведение считается нормальным?

11
задан 31 October 2019 в 00:12

0 ответов

Другие вопросы по тегам:

Похожие вопросы: