ошибка библиотеки Python, pandas [дубликат]

Я пытаюсь установить pandas на Ubuntu 14.04. Кажется, у меня проблема с зависимостями, но я не смог их установить. Я пытаюсь установить pandas через pip следующим образом:

vroni@zargedu4:~$ pip install pandas

И это сообщение об ошибке:

SystemError: Cannot compile 'Python.h'. Perhaps you need to install python-dev|python-devel.

Если я пытаюсь установить python-dev, происходит следующее:

vroni@zargedu4:~$ sudo apt-get install python-dev
python-dev :Depends: libpython-dev (= 2.7.5-5ubuntu3) but it is not installable
            Depends: python2.7-dev (>= 2.7.5-1~) but it is not installable

Он в основном пропускает эти зависимости. Попытка их установить приводит меня только к новым сообщениям, подобным этому.

vroni@zargedu4:~$ sudo apt-get install libpython-dev
libpython-dev : Depends: libpython2.7-dev (>= 2.7.5-1~) but it is not installable

и так далее.

vroni@zargedu4:~$ sudo apt-get install libpython2.7-dev
libpython2.7-dev : Depends: libpython2.7-stdlib (= 2.7.6-8) but 2.7.6-8ubuntu0.2 should be installed
                Depends: libpython2.7 (= 2.7.6-8) but 2.7.6-8ubuntu0.2 should be installed
                Depends: libexpat1-dev but it is not installable

пока я не попробую ..

vroni@zargedu4:~$ sudo apt-get install libpython2.7-stdlib=2.7.6-8ubuntu0.2

Тогда ответ: это уже самая новая версия.

libpython2.7-stdlib is already the newest version.

Я не совсем понимаю, в чем тут проблема. Я также пробовал:

sudo apt-get update
sudo apt-get upgrade
sudo apt-get install -f

и

sudo apt-get -f install

, а потом попытался снова установить панды. но вроде ничего не работает.

2
задан 30 August 2018 в 12:32

0 ответов

Другие вопросы по тегам:

Похожие вопросы: