Wine (wine32) требует зависимостей, которые не будут установлены Ubuntu 20.04

Поэтому, когда я пытаюсь установить только wine , это проходит без проблем, однако, очевидно, не устанавливает wine32, который необходим для приложений. Я хочу запустить.

Я уже добавил sudo dpkg --add-architecture i386

Однако когда я пытаюсь sudo apt install wine32 , я получаю следующие ошибки:

Building dependency tree       
Reading state information... Done
You might want to run 'apt --fix-broken install' to correct these.
The following packages have unmet dependencies:
 libavcodec58 : Breaks: libavcodec58:i386 (!= 7:4.2.4-1ubuntu0.1)
 libavcodec58:i386 : Depends: libaom0:i386 (>= 1.0.0) but it is not going to be installed
                     Depends: libavutil56:i386 (= 7:4.3.1-5) but it is not going to be installed
                     Depends: libcairo2:i386 (>= 1.2.4) but it is not going to be installed
                     Depends: libcodec2-0.9:i386 (>= 0.9.2) but it is not going to be installed
                     Depends: libdav1d4:i386 (>= 0.2.1) but it is not installable
                     Depends: libglib2.0-0:i386 (>= 2.12.0) but it is not going to be installed
                     Depends: libgsm1:i386 (>= 1.0.18) but it is not going to be installed
                     Depends: libmp3lame0:i386 (>= 3.100) but it is not going to be installed
                     Depends: libopenjp2-7:i386 (>= 2.0.0) but it is not going to be installed
                     Depends: libopus0:i386 (>= 1.1) but it is not going to be installed
                     Depends: librsvg2-2:i386 (>= 2.14.4) but it is not going to be installed
                     Depends: libshine3:i386 (>= 3.1.0) but it is not going to be installed
                     Depends: libsnappy1v5:i386 (>= 1.1.8) but it is not going to be installed
                     Depends: libspeex1:i386 (>= 1.2~beta3-1) but it is not going to be installed
                     Depends: libswresample3:i386 (= 7:4.3.1-5) but it is not going to be installed
                     Depends: libtheora0:i386 (>= 1.0) but it is not going to be installed
                     Depends: libtwolame0:i386 (>= 0.3.10) but it is not going to be installed
                     Depends: libva2:i386 (>= 2.2.0) but it is not going to be installed
                     Depends: libvorbis0a:i386 (>= 1.1.2) but it is not going to be installed
                     Depends: libvorbisenc2:i386 (>= 1.1.2) but it is not going to be installed
                     Depends: libvpx6:i386 (>= 1.6.0) but it is not going to be installed
                     Depends: libwavpack1:i386 (>= 4.40.0) but it is not going to be installed
                     Depends: libwebp6:i386 (>= 0.5.1) but it is not going to be installed
                     Depends: libwebpmux3:i386 (>= 0.6.1-2+b1) but it is not going to be installed
                     Depends: libx264-160:i386 (>= 2:0.160.3011+gitcde9a93) but it is not installable
                     Depends: libx265-192:i386 (>= 3.2) but it is not installable
                     Depends: libxvidcore4:i386 (>= 1.2.2) but it is not going to be installed
                     Depends: libzvbi0:i386 (>= 0.2.35) but it is not going to be installed
                     Breaks: libavcodec58 (!= 7:4.3.1-5)
 wine32:i386 : Depends: libwine:i386 (= 5.0-3ubuntu1) but it is not going to be installed
E: Unmet dependencies. Try 'apt --fix-broken install' with no packages

При более глубоком рассмотрении кажется, что есть 2 проблемы:

1) Некоторые зависимости «ломают» друг друга

2) Многие зависимости требуются в версии, которая просто недоступна в Ubuntu 20.04

Могу я как-нибудь принудительно установить wine32 для установки зависимостей с необходимыми версиями?

Замечание: вино сломалось после обновления Ubuntu 18.04 до 20.04, 18.04 я каким-то образом заставил его работать нормально с помощью добавления архитектуры и репозитория winehq ...

EDIT

хранилища
В настоящее время отключено (было включено, когда я пытался отладить это)
https://download.opensuse.org/repositories/Emulators:/Wine:/Debian/xUbuntu_18.04/ (обычный и исходный)
В настоящее время включено
https://dl.winehq.org/wine-builds/ubuntu/ (обычный и исходный)

вывод apt-cache policy wine32

wine32:i386:
  Installed: (none)
  Candidate: 5.0-3ubuntu1
  Version table:
     5.0-3ubuntu1 500
        500 http://archive.ubuntu.com/ubuntu focal/universe i386 Packages

вывод grep -ir ^ deb / etc / apt / --include = *. list

/etc/apt/sources.list:deb http://archive.ubuntu.com/ubuntu focal main universe restricted multiverse
/etc/apt/sources.list:deb http://security.ubuntu.com/ubuntu/ focal-security restricted universe multiverse main
/etc/apt/sources.list:deb http://archive.ubuntu.com/ubuntu focal-updates restricted universe multiverse main
/etc/apt/sources.list:deb http://archive.ubuntu.com/ubuntu focal-backports restricted universe multiverse main
/etc/apt/sources.list:deb https://dl.winehq.org/wine-builds/ubuntu/ focal main
/etc/apt/sources.list:deb-src https://dl.winehq.org/wine-builds/ubuntu/ focal main

Когда я отключил все эти репозитории и очистил все вино и запустил autoremove и clean, autoclean и apt update, затем попытался sudo apt install wine32 теперь вывод:

The following packages have unmet dependencies:
 wine32:i386 : Depends: libwine:i386 (= 5.0-3ubuntu1) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

Вывод политики apt-cache, wine32 остается таким же выводом grep -ir ^ deb / etc / apt / --include = *. list уменьшается из-за удаленных репозиториев.

РЕДАКТИРОВАТЬ 2:

apt-cache policy libwine:i386
libwine:i386:
  Installed: (none)
  Candidate: 5.0-3ubuntu1
  Version table:
     5.0-3ubuntu1 500
        500 http://archive.ubuntu.com/ubuntu focal/universe i386 Packages

dpkg -l | grep -i wine => нет результатов

sudo apt-get install libwine:i386
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 libwine:i386 : Depends: libfaudio0:i386 (>= 19.06.07) but it is not going to be installed
                Depends: libglib2.0-0:i386 (>= 2.12.0) but it is not going to be installed
                Depends: libgphoto2-6:i386 (>= 2.5.10) but it is not going to be installed
                Depends: libgstreamer-plugins-base1.0-0:i386 (>= 1.0.0) but it is not going to be installed
                Depends: libgstreamer1.0-0:i386 (>= 1.4.0) but it is not going to be installed
                Depends: libxml2:i386 (>= 2.9.0) but it is not going to be installed
                Recommends: libcups2:i386 (>= 1.4.0) but it is not going to be installed
                Recommends: libgssapi-krb5-2:i386 (>= 1.6.dfsg.2) but it is not going to be installed
                Recommends: libkrb5-3:i386 (>= 1.6.dfsg.2) but it is not going to be installed
                Recommends: libsane:i386 (>= 1.0.24) but it is not going to be installed
                Recommends: libxslt1.1:i386 (>= 1.1.25) but it is not going to be installed
                Recommends: gstreamer1.0-plugins-good:i386 but it is not going to be installed
E: Unable to correct problems, you have held broken packages.
2
задан 22 December 2020 в 17:52

0 ответов

Другие вопросы по тегам:

Похожие вопросы: