Доля NFS доступна с одного компьютера, но доступ отказан от другого [Закрыто]

Я настроил NFS доля на моей Raspberry PI, следуя к этому: https://www.raspberrypi.org/documentation/configuration/nfs.md My / etc / exports выглядит так:

pi@nextcloudpi:~ $ cat /etc/exports 
/export 192.168.1.0/24(rw,fsid=0,insecure,no_subtree_check,async)
/export/users   192.168.1.0/24(rw,nohide,insecure,no_subtree_check,async)

Я смонтировал его на своем рабочем столе (Ubuntu 20.04) без проблем, используя это:

sudo mount -t nfs -o proto=tcp,port=2049 192.168.1.48:/ /mnt

проблема в том, что когда я пытаюсь установить его на моем ноутбуке, который имеет в значительной степени Тот же Ubuntu, как мой рабочий стол, я получаю ошибку:

laptop:~$ sudo mount -t nfs -vvvv -o proto=tcp,port=2048 192.168.1.48:/ /mnt
mount.nfs: timeout set for Thu Feb 25 18:22:35 2021
mount.nfs: trying text-based options 'proto=tcp,port=2048,vers=4.2,addr=192.168.1.48,clientaddr=192.168.1.67'
mount.nfs: mount(2): Connection refused
mount.nfs: trying text-based options 'proto=tcp,port=2048,addr=192.168.1.48'
mount.nfs: prog 100005, trying vers=3, prot=6
mount.nfs: trying 192.168.1.48 prog 100005 vers 3 prot TCP port 60769
mount.nfs: mount(2): Permission denied
mount.nfs: access denied by server while mounting 192.168.1.48:/

Они оба в той же сети. Единственное различие, о которой я могу подумать, это то, что мой ноутбук Wi-Fi подключен, пока мой рабочий стол подключен Ethernet. Кто-нибудь знает, что может быть проблемой?

-1
задан 25 February 2021 в 20:35

1 ответ

Так оказывается, хороший ночной сон очень помогает. Если вы посмотрите внимательно, я использовал Port = 2049 на рабочем столе, а порт = 2048 на ноутбуке. Исправление опечатки было достаточно, чтобы исправить это.

0
ответ дан 18 March 2021 в 23:30

Другие вопросы по тегам:

Похожие вопросы: