Проблема зависимости при установке libgtk-3-dev Ubuntu 18.04 [Дубликат]

Я пытаюсь установить libgtk-3-dev и решить следующее сообщение:

user@nvidia-jetson-tx2:~/projects/realsense/librealsense$ sudo apt-get install libgtk-3-dev
[sudo] password for user: 
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help resolve the situation:

The following packages have unmet dependencies:
 libgtk-3-dev : Depends: libgtk-3-0 (= 3.22.30-1ubuntu1) but 3.22.30-1ubuntu4 is to be installed
                Depends: gir1.2-gtk-3.0 (= 3.22.30-1ubuntu1) but 3.22.30-1ubuntu4 is to be installed
                Depends: libpango1.0-dev (>= 1.40.5) but it is not going to be installed
                Depends: libatk-bridge2.0-dev but it is not going to be installed
                Depends: libcairo2-dev (>= 1.14.0) but it is not going to be installed
                Depends: libxkbcommon-dev but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

Если мое понимание правильно, определенные зависимости в Libgtk-3-dev ищут старую версию libgtk-3- 0 и GIR1.2-GTK-3.0 . Что было бы лучшим ходом действий для этих двух пакетов:

  • DONWGRADE Libgtk-3-0 и GIR1.2-GTK-3.0
  • Силовая установка libgtk -3-dev как-то игнорируя зависимости (не уверены, если это возможно вообще)
  • изменять зависимость (если возможно)
  • что-то еще?

Как насчет других 4 пакетов ( libpango1.0-dev, libatk-bridge2.0-dev, libcaRo2-dev, libxkbcommon-dev )? Где они не установлены, потому что критерии версии Libgtk-3-0 и и GIR1.2-GTK-3.0 не были выполнены или потенциально есть какой-то другой вопрос с ними?

Может ли кто-нибудь дать мне некоторую страницу о том, как продолжить?

Большое спасибо заранее!

1
задан 6 March 2021 в 01:22

1 ответ

Спасибо террасу за указываю на правильное направление.

Пришлось включить «рекомендуемые обновления (Bionic-Update)» в разделе программного обеспечения и обновления-> обновлениями и после этого, я смог установить libgtk-3-dev 3.22.30-1ubuntu4 даже без явного указания версия.

Рекомендуемые обновления (Bionic-Update)

1
ответ дан 18 March 2021 в 23:28

Другие вопросы по тегам:

Похожие вопросы: