Что делают опции --frontend и --режим для модернизация? [дубликат]

При проверке руководства для do-release-upgrade я обнаружил, что оно имеет аргумент --frontend , который может быть передан команде вместе со значением. Однако manpage не объясняет, что именно делает аргумент, или каковы доступные для него значения.

       -f FRONTEND, --frontend=FRONTEND
              Run the specified frontend

Я предполагаю, что это позволит нам пройти через конкретное приложение, такое как программа обновления программного обеспечения или командная строка. Могу ли я найти лучшее описание и список возможных значений для этого аргумента?

-121--889385- Не удается установить mono [duplicate] Я застрял и не могу установить mono-devel на мой компьютер. Я установил моноклиринг и репо, но всякий раз, когда я пытаюсь установить его, я получаю следующее: Не удалось установить некоторые пакеты. Это может означать...

В настоящее время я застрял и не могу установить моноблок на свой компьютер. Я установил моноклиринг и репо, но всякий раз, когда я пытаюсь установить его, я получаю следующее:

Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 mono-devel : Depends: mono-runtime (>= 3.0~) but it is not going to be installed
              Depends: libc6 (>= 2.31) but 2.28-10 is to be installed or
                       libc6.1 (>= 2.31) but it is not installable or
                       libc0.1 (>= 2.31) but it is not installable
              Depends: libglib2.0-0 (>= 2.64.6) but 2.58.3-2+deb10u2 is to be installed
              Depends: libmono-cecil-private-cil (>= 6.12.0.122) but it is not going to be installed
              Depends: libmono-cecil-private-cil (< 6.12.0.123) but it is not going to be installed
              Depends: libmono-codecontracts4.0-cil (>= 1.0) but it is not going to be installed
              Depends: libmono-compilerservices-symbolwriter4.0-cil (>= 3.6.0) but it is not going to be installed
              Depends: libmono-corlib4.5-cil (>= 4.0.0~alpha1) but it is not going to be installed
              Depends: libmono-peapi4.0a-cil (>= 3.2.8) but it is not going to be installed
              Depends: libmono-relaxng4.0-cil (>= 2.10.1) but it is not going to be installed
              Depends: libmono-security4.0-cil (>= 3.0.6) but it is not going to be installed
              Depends: libmono-system-configuration-install4.0-cil (>= 1.0) but it is not going to be installed
              Depends: libmono-system-configuration4.0-cil (>= 4.0.0~alpha1) but it is not going to be installed
              Depends: libmono-system-core4.0-cil (>= 4.0.0~alpha1) but it is not going to be installed
              Depends: libmono-system-data4.0-cil (>= 4.0.0~alpha1) but it is not going to be installed
              Depends: libmono-system-drawing4.0-cil (>= 3.0.6) but it is not going to be installed
              Depends: libmono-system-io-compression-filesystem4.0-cil (>= 3.2.1) but it is not going to be installed
              Depends: libmono-system-runtime-serialization4.0-cil (>= 4.0.0~alpha1) but it is not going to be installed
              Depends: libmono-system-runtime4.0-cil (>= 2.10.1) but it is not going to be installed
              Depends: libmono-system-security4.0-cil (>= 1.0) but it is not going to be installed
              Depends: libmono-system-servicemodel4.0a-cil (>= 3.2.3) but it is not going to be installed
              Depends: libmono-system-web-services4.0-cil (>= 1.0) but it is not going to be installed
              Depends: libmono-system-xml-linq4.0-cil (>= 3.0.6) but it is not going to be installed
              Depends: libmono-system-xml4.0-cil (>= 3.12.0) but it is not going to be installed
              Depends: libmono-system4.0-cil (>= 4.0.0~alpha1) but it is not going to be installed
              Depends: mono-mcs (= 6.12.0.122-0xamarin1+ubuntu2004b1) but it is not going to be installed
              Depends: mono-roslyn (= 6.12.0.122-0xamarin1+ubuntu2004b1) but it is not going to be installed
              Depends: mono-gac (= 6.12.0.122-0xamarin1+ubuntu2004b1) but it is not going to be installed
              Depends: mono-xbuild (= 6.12.0.122-0xamarin1+ubuntu2004b1) but it is not going to be installed
              Depends: libmono-cil-dev (= 6.12.0.122-0xamarin1+ubuntu2004b1) but it is not going to be installed
              Depends: libmono-2.0-dev (>= 6.12.0.122-0xamarin1+ubuntu2004b1) but it is not going to be installed
              Depends: libmono-2.0-dev (< 6.12.0.122-0xamarin1+ubuntu2004b1.1~) but it is not going to be installed
              Depends: ca-certificates-mono (= 6.12.0.122-0xamarin1+ubuntu2004b1) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

Пожалуйста, помогите, спасибо всем.

0
задан 24 February 2021 в 17:41

1 ответ

Установите версию, которая создана для вашей системы, не последний доступный. У вас есть 20.04, пытаясь установить пакеты, созданные как минимум 20.10, переходя от ошибки libc6. Когда вы добавляете репозиторий в свою установку, они должны быть одинакового выпуска, или они никогда не будут установлены.

1
ответ дан 18 March 2021 в 23:31

Другие вопросы по тегам:

Похожие вопросы: