Не удается выполнить sudo apt-get обновление с ошибками от gnome3-team/gnome3/ubuntu focal Release [дубликат]

При обновлении я получаю следующее сообщение об ошибке:

W: The repository 'http://ppa.launchpad.net/mc3man/trusty-media/ubuntu xenial Release' does not have a Release file.

Здесь я нахожу другое утверждение об этой ошибке: Как исправить ошибку 404 при использовании PPA или обновлении списков пакетов?

Это рекомендует удалить некоторые PPA; и, я не уверен, стоит ли мне это делать, поскольку это может означать, что я не получу нужные мне обновления.

Это то, что я должен сделать?

-121--888771- Выключить монитор Я только что обновил до 20.04 с 18 для моего сервера Ubuntu, который работает на ноутбуке. У меня есть псевдоним, который запускается при запуске и использует vbetool для отключения экрана sudo sh -c 'vbetool dpms off; read ans;...

Я только что обновил до 20.04 с 18 для моего сервера Ubuntu, который работает на ноутбуке. У меня есть псевдоним, который запускается при запуске, который использует vbetool, чтобы отключить экран

sudo sh -c 'vbetool dpms off; read ans; vbetool dpms on'

, но он не работает сейчас на 20. Когда я пытаюсь запустить псевдоним вручную, я получаю:

mmap /dev/zero: Operation not permitted
Failed to initialise LRMI (Linux Real-Mode Interface).

Я просто хочу, чтобы экран ноутбука выключился после загрузки. Любая помощь будет оценена.

0
задан 2 March 2021 в 21:02

1 ответ

У меня есть подобный скрипт, который будет работать с установленным XServer:

xset -display :0 dpms force off;
#do sth
xset dpms force on

, который работает на разных дистрибутах. Использование -display - это просто предосторожность, это может работать без него, в зависимости от того, как вы начнете его.

0
ответ дан 18 March 2021 в 23:29

Другие вопросы по тегам:

Похожие вопросы: