Установка Java OpenJDK, не работающая, [закрылась]

я недавно двойная загруженная Ubuntu с моим Windows, таким образом, я являюсь абсолютно новым. Я кодировал в Java на моей машине Windows, но хотел бы сделать это на Ubuntu теперь. Однако при попытке следовать учебным руководствам (например, , Как я устанавливаю Java? ) я получаю ошибки в своем терминале, который я добавлю здесь.

milan@milan-Inspiron-7559:~$ sudo apt-get install default-jre
[sudo] password for milan: 
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following additional packages will be installed:
  ca-certificates-java default-jre-headless fonts-dejavu-extra java-common
  libatk-wrapper-java libatk-wrapper-java-jni openjdk-11-jre
  openjdk-11-jre-headless
Suggested packages:
  fonts-ipafont-gothic fonts-ipafont-mincho fonts-wqy-microhei
  | fonts-wqy-zenhei
The following NEW packages will be installed:
  ca-certificates-java default-jre default-jre-headless fonts-dejavu-extra
  java-common libatk-wrapper-java libatk-wrapper-java-jni openjdk-11-jre
  openjdk-11-jre-headless
0 upgraded, 9 newly installed, 0 to remove and 7 not upgraded.
Need to get 37.5 MB/39.5 MB of archives.
After this operation, 178 MB of additional disk space will be used.
Do you want to continue? [Y/n] Y
Ign:1 http://za.archive.ubuntu.com/ubuntu eoan-updates/main amd64 openjdk-11-jre-headless amd64 11.0.7+10-2ubuntu2~19.10
Ign:2 http://za.archive.ubuntu.com/ubuntu eoan-updates/main amd64 openjdk-11-jre amd64 11.0.7+10-2ubuntu2~19.10
Ign:3 http://za.archive.ubuntu.com/ubuntu eoan/main amd64 libatk-wrapper-java all 0.35.0-3
Err:4 http://za.archive.ubuntu.com/ubuntu eoan/main amd64 libatk-wrapper-java-jni amd64 0.35.0-3
  404  Not Found [IP: 197.155.77.2 80]
Err:3 http://za.archive.ubuntu.com/ubuntu eoan/main amd64 libatk-wrapper-java all 0.35.0-3
  404  Not Found [IP: 197.155.77.2 80]
Err:1 http://security.ubuntu.com/ubuntu eoan-updates/main amd64 openjdk-11-jre-headless amd64 11.0.7+10-2ubuntu2~19.10
  404  Not Found [IP: 197.155.77.2 80]
Err:2 http://security.ubuntu.com/ubuntu eoan-updates/main amd64 openjdk-11-jre amd64 11.0.7+10-2ubuntu2~19.10
  404  Not Found [IP: 197.155.77.2 80]
E: Failed to fetch http://security.ubuntu.com/ubuntu/pool/main/o/openjdk-lts/openjdk-11-jre-headless_11.0.7+10-2ubuntu2~19.10_amd64.deb  404  Not Found [IP: 197.155.77.2 80]
E: Failed to fetch http://security.ubuntu.com/ubuntu/pool/main/o/openjdk-lts/openjdk-11-jre_11.0.7+10-2ubuntu2~19.10_amd64.deb  404  Not Found [IP: 197.155.77.2 80]
E: Failed to fetch http://za.archive.ubuntu.com/ubuntu/pool/main/j/java-atk-wrapper/libatk-wrapper-java_0.35.0-3_all.deb  404  Not Found [IP: 197.155.77.2 80]
E: Failed to fetch http://za.archive.ubuntu.com/ubuntu/pool/main/j/java-atk-wrapper/libatk-wrapper-java-jni_0.35.0-3_amd64.deb  404  Not Found [IP: 197.155.77.2 80]
E: Unable to fetch some archives, maybe run apt-get update or try with --fix-missing?
milan@milan-Inspiron-7559:~$ apt-get update
Reading package lists... Done
E: Could not open lock file /var/lib/apt/lists/lock - open (13: Permission denied)
E: Unable to lock directory /var/lib/apt/lists/
W: Problem unlinking the file /var/cache/apt/pkgcache.bin - RemoveCaches (13: Permission denied)
W: Problem unlinking the file /var/cache/apt/srcpkgcache.bin - RemoveCaches (13: Permission denied)

я ценил бы любую справку.

0
задан 26 February 2021 в 16:27

1 ответ

Необходимо поместить оценку в «подстановку команд», например:

eval "$(dircolors /home/neil/gnome-terminal-colors-solarized/dircolors)"

Тогда она должна работать без вывода выходных данных (тот же путь, что и в .bashrc в разделе # enable color support ).

-121--909383-

При вводе пароля в терминале (это не относится только к sudo, каждое приложение cli, которое я лично использовал и которое запрашивает пароль, также имеет одинаковое поведение), на экране не будет записываться никаких символов. Не волнуйтесь, вы вводите их, просто введите пароль и нажмите клавишу Enter, как только закончите. Если вы ошиблись, это вам скажет.

-121--909401-

Обновление до Ubuntu 20.04 LTS решило эту проблему.

0
ответ дан 18 March 2021 в 23:30

Другие вопросы по тегам:

Похожие вопросы: